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คํานํา 

 ตามที่ สํานักงานปลัดกระทรวงสาธารณสุข โดยสํานักนโยบายและยุทธศาสตร์        
ได้ดําเนินการจัดอบรม “การให้รหัส และการประเมินตรวจสอบคุณภาพการให้รหัสโรคและรหัส
หัตถการ สําหรับผู้รับผิดชอบ Data Center ระดับจังหวัด และเขตเครือข่ายบริการสุขภาพ” เป็นราย
ภาค โดยมีวัตถุประสงค์ 1) เพ่ือให้เจ้าหน้าที่ที่รับผิดชอบงานข้อมูลสุขภาพในระดับจังหวัดและเขต
เครือข่ายบริการ มีความรู้ความเข้าใจ แนวทางการบันทึกข้อมูลบริการ คําวินิจฉัยโรคและการให้รหัส
โรค และการมารับบริการสุขภาพ ได้อย่างถูกต้อง และครบถ้วน เป็นมาตรฐานเดียวกัน 2) มีความรู้
ความเข้าใจ แนวทางการตรวจสอบคุณภาพการให้รหัสโรค และหัตถการในหน่วยบริการในเขต
รับผิดชอบได้ และ 3) เพ่ือให้ข้อมูลการให้รหัสโรค รหัสหัตถการและการบันทึกข้อมูลตามแฟ้มโครงสร้าง
มาตรฐานใน Health Data Centre มีความถูกต้อง มีคุณภาพตรงตามมาตรฐาน  เสร็จเรียบร้อยไปแล้ว
ต้ังแต่เดือนเมษายน 2558 ที่ผ่านมาน้ัน 
  จากการดําเนินการดังกล่าว สํานักนโยบายและยุทธศาสตร์ได้คํานึงถึงภาระงานที่จะ
เพ่ิมขึ้นในระดับจังหวัดและเขตเครือข่ายบริการสุขภาพ และเป็นภารกิจที่ต้องดําเนินการต่อเน่ืองจาก
การอบรมดังกล่าวข้างต้น และประเด็นที่สําคัญคือ หน่วยงานที่รับผิดชอบ Health Data Centre ใน
ระดับจังหวัดต้องการแนวทาง หรือ เครื่องมือในการวิเคราะห์คุณภาพข้อมูลดังกล่าว เพ่ือทราบ
สถานการณ์คุณภาพข้อมูลและสถานะสุขภาพในเขตพื้นที่ความรับผิดชอบของตนเองได้ จึงดําเนิน
โครงการอบรมการวิเคราะห์และนําเสนอผลการวิเคราะห์คุณภาพข้อมูลการให้รหัสโรค (ICD-10-TM) 
ในคลังข้อมูลสุขภาพ (Health Data Centre) ให้ใช้เป็นแนวทาง เครื่องมือตรวจ กรอง และวิเคราะห์
คุณภาพข้อมูลการให้รหัส ที่เป็นประเด็น กฎเกณฑ์ต่างๆ ให้เป็นมาตรฐานเดียวกันทั้งประเทศ ซึ่งจะทํา
ให้ลดภาระงานดังกล่าวได้มาก โดยการวิเคราะห์คุณภาพข้อมูลการให้รหัสโรคน้ี จะมีขั้นตอนที่สําคัญ 
ดังน้ี 

1. การทําให้ข้อมูลมองเห็นได้ (Data Visualization) 
2. การใช้การคํานวณเพ่ือวิเคราะห์ความหมายด้านต่างๆของข้อมูล 
3. การนําเสนอข้อมูลที่วิเคราะห์แล้วในรูปแบบสารสนเทศ เพ่ือนําไปใช้ประโยชน์ เช่น 

การเปรียบเทียบข้อมูลสุขภาพเป็นรายอําเภอ รายจังหวัด รายเขตเครือข่ายบริการสุภาพ หรือ กลุ่มโรค
หลักที่ผู้ป่วยเป็นมากที่สุด เป็นต้น 

 สํานักนโยบายและยุทธศาสตร์ จึงจัดทําคู่มือการสร้างคลังข้อมูลเพ่ือการวิเคราะห์
คุณภาพการให้รหัส ICD ในคลังข้อมูลสุขภาพ / สถานพยาบาล เพ่ือใช้เป็นคู่มือประกอบการดําเนินการ
ในการวิเคราะห์การให้รหัส ICD ดังกล่าว 

 
 

    สํานักนโยบายและยุทธศาสตร์ 
มิถุนายน 2558 
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บทที่ 1  บทนําสูการสรางคลังขอมูลและการวิเคราะหขอมูลโรงพยาบาลเพื่อคนหาโอกาสการพัฒนา 

บทที่ 2  การจัดเตรียม ตรวจสอบ และแกไขคุณภาพขอมูลกอนนําเขาคลังขอมูล
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บทที่ 7  การวิเคราะหลําดับ (Ranking Analysis)

บทที่ 8  การวิเคราะหความผิดพลาดของการใหรหัส (ICD Coding Error Analysis)

บทที่ 9  การปรับแตงคลังขอมูลใหมีประสิทธิภาพ ใชงานงาย   

บทที่ 10  การเพิ่มเติมขอมูลเขาสูคลังขอมูลใหทันสมัยอยางตอเน่ือง
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บทท่ี 1   

บทนําสูการสรางคลังขอมูลและการวิเคราะหขอมูลโรงพยาบาลเพื่อคนหาโอกาส

การพัฒนา 
 

การวิเคราะหขอมูลในโรงพยาบาลเปนส่ิงที่ทําไดงายขึ้นในปจจุบันเพราะเราสามารถใชเทคโนโลยีสารสนเทศ

ชวยในการวิเคราะหขอมูลไดอยางสะดวก รวดเร็วกวาในอดีต อยางไรก็ตาม โรงพยาบาลหลายแหงยังไมไดวิเคราะหขอมูล

ในระบบคอมพิวเตอรของโรงพยาบาลอยางเต็มที่ บางแหงจัดทําเพียงสถิติทั่วๆไป ไมไดนําขอมูลมาพัฒนาใหเกิดองค

ความรูที่จะใชพัฒนาโรงพยาบาลตอไป 

 ขอมูลในระบบคอมพิวเตอรของโรงพยาบาลแตละแหงกําลังเพิ่มขึ้นอยางตอเน่ือง เพราะโรงพยาบาลสวนใหญ

ในประเทศไทยไดนําระบบคอมพิวเตอรมาใชจัดการขอมูลการดําเนินงานมานานนับสิบป ระบบจัดเก็บขอมูลในปจจุบัน

สามารถจัดเก็บขอมูลปริมาณมากมายมหาศาลโดยที่มีราคาถูกลงเรื่อยๆ ระบบการคิดคํานวณของหนวยประมวลผลก็

สามารถคํานวณไดอยางรวดเร็วมากและมีราคาถูกลงเชนกัน และโปรแกรมที่ใชวิเคราะหขอมูลที่ออกมาใหมจํานวนมากก็

เปนโปรแกรมที่มีความสามารถสูงและราคาต่ําหรือเปนโปรแกรมที่ใหใชงานฟรี ปจจัยเหลาน้ีทําใหการวิเคราะหขอมูลใน

ระบบคอมพิวเตอรของโรงพยาบาลสามารถสกัดขอมูลที่ตองการไดอยางมากมาย ภายในเวลาไมนาน จึงควรวิเคราะห

ขอมูลอยางสมํ่าเสมอในแงมุมตางๆ เพื่อชวยการตัดสินใจใหมีประสิทธิภาพ และหาโอกาสการพัฒนา 

 
ลักษณะทั่วไปของขอมูล 

 ขอมูล คือ ขอเท็จจริง ที่เกิดขึ้นจากเหตุการณตางๆ และมาจากการจดบันทึกของคน หรือบันทึกดวยระบบ

อัตโนมัติ มนุษยจะรับขอมูลจากเหตุการณตางๆดวยการสังเกต การนับ การวัด การซักถามผูอ่ืน แลวบันทึกโดยการจดจํา 

หรือเขียนลงในส่ือที่ใชบันทึกขอมูล ในปจจุบัน มนุษยไดสรางระบบที่สามารถชวยนับ วัด จับภาพ จับเสียง แลวบันทึกลง

ส่ือบันทึกขอมูลโดยอัตโนมัติ ทําใหเรามีขอมูลมากมายที่สามารถเลือกมาใชประโยชนได 

 เราสามารถจําแนกขอมูลทั่วไปไดเปน 2 ประเภท [1] คือ ขอมูลที่ใชคํานวณได และขอมูลที่ใชคํานวณไมได 

โดยขอมูลที่ใชคํานวณได ตองเปนขอมูลแบบตัวเลข (Numeric) สวนขอมูลที่ใชคํานวณไมไดอาจเปนตัวเลข เปน

ขอความ เปนภาพ เสียง หรือส่ือผสม ก็ได 

 ขอมูลที่ใชคํานวณได ตองเปนแบบตัวเลข เพื่อใหสามารถนําไป บวก ลบ คูณ หาร ได สวนขอมูลที่คํานวณไมได 

มี 2 ลักษณะ คือ ขอมูลที่เปนขอความ เปนเสียง ภาพ ส่ือผสม ที่ไมสามารถนําไปบวก ลบ คูณ หาร ได กับขอมูลที่เปน

ตัวเลข แตไมสมควรนําไปคํานวณ เชน เลขรหัสประจําตัวประชาชน หมายเลขโทรศัพท 

 

การวิเคราะหขอมูล 

 การวิเคราะหขอมูล หมายถึง การจําแนกแยกแยะเน้ือหาในขอมูล เพื่อคนหาวาขอมูลมีลักษณะเปนอยางไร มี

องคประกอบยอยๆอะไรบาง ประกอบกันขึ้นมาไดอยางไร และมีความสัมพันธเชื่อมโยงกันอยางไร 

 กอนยุคเทคโนโลยีสารสนเทศ มนุษยใชสมองเปนเครื่องมือหลักในการวิเคราะหขอมูล โดยมีเครื่องมือรอง ไดแก 

ลูกคิดหรือเครื่องชวยคํานวณรูปแบบตางๆ บันทึกลักษณะขอมูลเดิมเพื่อใชเปรียบเทียบ การวิเคราะหขอมูลของมนุษย

สามารถใชวิเคราะหขอมูลไดทุกแบบ ทั้งขอมูลที่ใชคํานวณได และขอมูลที่ใชคํานวณไมได แตความรวดเร ็วในการ

วิเคราะหขอมูลของมนุษยคงจะสูความรวดเร็วของเทคโนโลยีสารสนเทศไมด 



2 
 

 ในยุคปจจุบัน เราสามารถใชเทคโนโลยีสารสนเทศชวยวิเคราะหขอมูล ทําใหเรามีทางเลือก 2 แบบในการ

วิเคราะหขอมูล อยางไรก็ตาม การใชเทคโนโลยีสารสนเทศจะชวยใหสามารถวิเคราะหขอมูลประเภทที่ใชคํานวณไดอยาง

รวดเร็วกวาเดิมหลายเทา แตการใชเทคโนโลยีสารสนเทศจะมีขอจํากัดในการวิเคราะหขอมูลประเภทที่ใชคํานวณไมได 

ดังเชน เราสามารถใชโปรแกรมคอมพิวเตอรคํานวณคาเฉล่ียรายไดของคน 1 ลานคน ไดในเวลาชั่วพริบตา แตเราไม

สามารถใชโปรแกรมคอมพิวเตอรใดๆ วิเคราะหบทสัมภาษณบุคคลใด แลวสรุปความเชื่อ ทัศนคติ ของบุคคลน้ันออกมา

ได เพราะขอมูลในบทสัมภาษณเปนขอมูลประเภทที่ใชคํานวณไมได ตองใชมนุษยเปนผูวิเคราะหเทาน้ัน 

 อยางไรก็ตาม เรายังสามารถใชโปรแกรมคอมพิวเตอรชวยวิเคราะหขอมูลประเภทที่ใชคํานวณไมได แตตองมี

การจัดเตรียมขอมูลใหเหมาะสม โดยตองแปลงขอมูลที่ตองการวิเคราะหใหเปนตัวเลข เชน ขอมูลเพศ ตองกําหนดใหเพศ

ชายเปนเลข 1 เพศหญิงเปนเลข 2 หรือ ขอมูลระดับการศึกษา กําหนดให ระดับต่ํากวาปริญญาเปน เลข 1 ปริญญาตรี

หรือโท เปนเลข 2 ปริญญาเอกเปนเลข 3 เปนตน 

 เรายังสามารถโปรแกรมคอมพิวเตอรขั้นสูงวิเคราะหขอมูลประเภทที่ใชคํานวณไมได โดยอาศัยอัลกอริธึมที่

สลับซับซอน เชน เราสามารถวิเคราะหบทสัมภาษณบุคคล โดย Natural language processing algorithm 

หรือ สามารถวิเคราะหภาพโดยใช Image processing algorithm ได แตในตําราเลมน้ี จะไมครอบคลุมเน้ือหา

เหลาน้ัน 

 

ลักษณะขอมูลที่เหมาะสมกับการวิเคราะหดวยคอมพิวเตอร 
 ขอมูลที่เราจะใชโปรแกรมคอมพิวเตอรชวยวิเคราะหควรจะเปนตัวเลข โดยขอมูลที่เปนตัวเลขอยูแลว เราไม

ตองจัดเตรียมอะไรเพิ่มเติม นอกจากกํากับไววาเปนตัวเลขที่จะนําไปคํานวณหรือไม (ขอมูลที่เปนตัวเลขบางตัวไมควร

นําไปคํานวณ เชน เลขประจําตัวประชาชน) สําหรับขอมูลที่ยังไมเปนตัวเลข จะตองนําไปจัดกลุม กําหนดเลขของแตละ

กลุมออกมา แลวเปล่ียนขอมูลใหกลายเปนตัวเลขตามกลุม ก็จะนําไปวิเคราะหดวยโปรแกรมได 

 การแปลงขอมูลที่ยังไมเปนตัวเลขใหกลายเปนตัวเลข จะทําใหขอมูลมีลักษณะที่สามารถจําแนกความแตกตาง

ระหวางกลุมได อยางไรก็ตาม ขอมูลเหลาน้ีอาจมีลักษณะที่แตกตางกันเปน 4 แบบ ดังน้ี 

1. ขอมูลระดับนามบัญญัติ (Nominal scale) มีลักษณะการจําแนกเปนกลุม เปนพวก เทาน้ัน ไมสามารถ

บอกความแตกตางระหวางกลุมได เชน กําหนดให 1 แทน เพศชาย 2 แทนเพศหญิง ไมไดหมายความวาหญิงมีลักษณะ 

มากกวา ชาย เทากับ 2-1 = 1 ดังน้ัน ขอมูลแบบน้ีจึงนําไป บวก ลบ คูณ หารกันไมได ทําไดเพียงแค นับ แลวหาคา

สัดสวนเปนรอยละ เชน คํานวณวามีชายและหญิงรอยละเทาไรเพียงเทาน้ัน 

2. ขอมูลระดับเรียงอันดับ (Ordinal scale) มีลักษณะการจําแนกเปนกลุม เชนเดียวกับขอมูลนามบัญญัติ 

แตสามารถบอกความแตกตางของกลุมไดอยางคราวๆ เชน ระดับความพึงพอใจ 1 แทน นอยที่สุด 2 แทน นอย 3 แทน

ปานกลาง 4 แทนมาก 5 แทนมากที่สุด เราสามารถดูขอมูลแลวบอกไดวา ความพึงพอใจเปนแบบใด และยังบอกไดวา 

ระดับ 5 มากกวาระดับ 2 อยู 3 ระดับ ดวย ดังน้ัน ขอมูลแบบน้ี เราสามารถนําไปนับ หาคาสัดสวนเปนรอยละ และ

นําไป ลบกันเพื่อหาระดับความแตกตางไดดวย 

3. ขอมูลระดับชวง (Interval scale) มีลักษณะการจําแนกเปนชวง สามารถบอกความแตกตางของแตละ

ชวงได เชน ขอมูลเกรดของนักศึกษา เราสามารถบอกไดวา เกรด 4 สูงกวา เกรด 2 อยางไรก็ตาม เกณฑการใหเกรดใน

แตละสถาบันอาจแตกตางกันไป ทําใหไมสามารถคํานวณเกรดนักศึกษาตางสถาบันรวมกันได แตยังถือวา ขอมูลระดับชวง

น้ี นําไปคํานวณไดมากกวาขอมูลระดับเรียงลําดับและนามบัญญัต ิ
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4. ขอมูลระดับอัตราสวน (Ratio scale) มีลักษณะที่สามารถจําแนกกลุมและบอกความแตกตางระหวาง

กลุมเปนตัวเลขไดอยางสมบูรณแบบ มีจุดเริ่มตนคงที่ เชน เริ่มที่ 0 ตัวอยางของขอมูลประเภทน้ี ไดแก นํ้าหนัก สวนสูง 

คะแนนสอบ ฯลฯ เราสามารถนําขอมูลลักษณะน้ีไปคํานวณไดทุกรูปแบบ 

 
ขอมูลทั้ง 4 ระดับ อาจจัดรวมเปน 2 กลุม คือ ขอมูลคุณภาพ (Quantitative data) ประกอบดวย ขอมูล

ระดับ นามบัญญัติ และ เรียงอันดับ และขอมูลปริมาณ (Qualitative data) ประกอบดวย ขอมูลระดับ ชวง และ 

อัตราสวน 

 

ลักษณะของขอมูลในระบบโรงพยาบาล 

 ขอมูลในระบบโรงพยาบาล จะมีลักษณะเฉพาะไมเหมือนขอมูลอ่ืนทั่วไป เพราะในโรงพยาบาลมีขอมูลที่

แตกตาง 6 กลุม ตามลักษณะกลุมโครงสรางของระบบโรงพยาบาล [2] ดังน้ี  

1. ขอมูลผูปวย เปนขอมูลระบุตัวผูปวย ลักษณะทางประชากรศาสตร สถานภาพสมรส สิทธิการรักษา ที่อยู 

ฯลฯ ขอมูลเหลาน้ีจะเปล่ียนแปลงเม่ือผูปวยยายที่อยู เปล่ียนที่ทํางาน แตงงาน มีลูก ตามกิจกรรมของผูปวย เจาหนาที่

เวชระเบียนควรหม่ันปรับปรุงขอมูลผูปวยใหทันสมัยโดยขอขอมูลเพิ่มเติมเปนระยะ 

2. ขอมูลกิจกรรมการบริการผูปวย  เปนขอมูลที่มีมากที่สุดในทุกโรงพยาบาล เก็บรายละเอียดการบริการ

ผูปวยทุกครั้ง ไดแก ขอมูลการมาตรวจ การจายยา คารักษา ผลการตรวจทางหองปฏิบัติการ ฯลฯ ผูบันทึกขอมูลคือผูที่

ดูแลผูปวยทุกคน ตั้งแต แพทย พยาบาล เภสัชกร เจาหนาที่หอง Lab เจาหนาที่การเงิน ฯลฯ  

3. ขอมูลทรัพยากร เปน ขอมูลการจัดสรรทรัพยากรในการรักษาพยาบาลผูปวย ไดแก ขอมูลตารางนัด ตาราง

การผาตัด จํานวนเตียงวาง รายการยาที่มีในโรงพยาบาล จํานวนแพทยสาขาตางๆ ฯลฯ ขอมูลลักษณะน้ีจะมีผูบันทึก

ขอมูลเพียงไมก่ีคน แตมีผูใชขอมูลจํานวนมากที่ตองเรียกดูขอมูลเหลาน้ีอยูบอยๆ 

4. ขอมูลทางคลินิก เปนขอมูลที่ชวยใหแพทย พยาบาล และเจาหนาที่ที่บําบัดรักษาผูปวยโดยตรงตองใช

เพื่อใหการดูแลรักษาอยางตอเน่ืองมีคุณภาพที่ดี ไดแก ประวัติการเจ็บปวย ผลการตรวจรางกาย การวินิจฉัย รายงานการ

ผาตัด การใหการพยาบาล บันทึกทางกายภาพบําบัด ฯลฯ ขอมูลลักษณะน้ี ใชเพื่อส่ือสารระหวางแพทย พยาบาล และผู

มีหนาที่บําบัดรักษาผูปวย เพื่อใหรายละเอียดชวยการตัดสินใจที่ด ี

5. ขอมูลการบริหาร เปนขอมูลเพื่อชวยใหการบริหารโรงพยาบาลเปนไปอยางมีประสิทธิภาพ ไดแก ขอมูล

ตนทุนคายา คารักษาตางๆ ขอมูล username, password ขอมูลการปวย ลา ขาด สายของบุคลากร ฯลฯ ขอมูล

ลักษณะน้ีอาจไดมาจากการบันทึก หรือไดจากการคํานวณขอมูลอ่ืนๆประกอบกัน 

6. ขอมูลอางอิง เปนขอมูลที่ใชเรียกดูประกอบการตัดสินใจ ไดแก ตารางยาที่ออกฤทธ์ิรบกวนกัน รายการยาที่

เบิกคารักษาได รายการคารักษาที่เบิกได หรือ เบิกไมได ฯลฯ ขอมูลน้ีสวนใหญมาจากองคกรภายนอกของโรงพยาบาล 

ผูดูแลระบบจะเปนผูรับผิดชอบใหขอมูลกลุมน้ีทันสมัยอยูเสมอ 

ขอมูลที่ควรนํามาใชวิเคราะหเปนระยะไดแก ขอมูลกลุมที่ 1 ผูปวย 2 กิจกรรม 3 ทรัพยากร และ 5 บริหาร 

เพื่อใหรูวาลักษณะผูมารับบริการเปนกลุมไหน กิจกรรมและการใชทรัพยากรเปนอยางไร ควรบริหารอยางไรใหมี

ประสิทธิภาพ 
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การวิเคราะหขอมูลผูปวย 

ขอมูลผูปวย เปนขอมูลที่สําคัญเพราะผูปวยเปนผูมารับบริการรักษาพยาบาล หากเราเขาใจลักษณะของผูมารับ

บริการเปนอยางดี เรายอมสามารถปรับบริการของโรงพยาบาลใหสอดคลองกับผูปวย เพิ่มความสะดวกสบายและความ

พึงพอใจของผูปวยได ผูปวยและญาติก็จะเกิดความรูสึกที่ประทับใจ ลดโอกาสรองเรียนได ตัวอยางการวิเคราะหขอมูล

ผูปวยไดแก 

- สัดสวน เพศ อายุ ภูมิลําเนา เชื้อชาติ สัญชาติ ของผูปวย 

- สัดสวนสถานภาพสมรส อาชีพ สถานที่ทํางาน 

- สัดสวน สิทธิการรักษาของผูปวย เรียงตามลําดับที่มีสัดสวนมากไปนอย 

- กลุมโรคหลักที่ผูปวยเปนมากที่สุด 30 อันดับแรก 

- โรคประจําตัวที่ผูปวยเปนมากที่สุด 10 อันดับแรก 

- การผาตัดที่ผูปวยไดรับกันมากที่สุด 20 อันดับแรก 

- แนวโนมการเปล่ียนแปลงลักษณะผูปวยในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

การวิเคราะหขอมูลกิจกรรมการรักษาพยาบาล 

ขอมูลกิจกรรม เปนขอมูลที่มีมากที่สุดในระบบคอมพิวเตอรโรงพยาบาล เพราะเราใชคอมพิวเตอรบันทึกขอมูล

กิจกรรมเหลาน้ีตลอดเวลา เริ่มจากจุดยื่นบัตร ไปจนพบพยาบาล พบแพทย ตรวจ Lab X-Rays จายยา จายเงิน จน

ผูปวยกลับบาน จึงเปนขอมูลที่วิเคราะหไดมากที่สุด ตัวอยางการวิเคราะหขอมูลกิจกรรม ไดแก 

- จํานวนผูปวยที่มารับบริการตาม OPD หรือจุดบริการตางๆ 

- จํานวน และสัดสวนการตรวจทางหองปฏิบัติการ การตรวจพิเศษ การตรวจทางรังสีวิทยา 

- คาใชจายเพื่อบริการตางๆ เชน คายา คาตรวจทางหองปฏิบัติการ คาตรวจพิเศษ 

- ระยะเวลาที่รอคิว ระยะเวลาที่ใหบริการในจุดตางๆ  

- จํานวน และ สัดสวนการใหบริการจําแนกตามแพทย พยาบาล บุคลากรอ่ืนๆ 

- จํานวนและสัดสวนผูปวยที่มาตรวจตามนัด และไมมาตามนัด 

- แนวโนมการเปล่ียนแปลงจํานวน และสัดสวนการใหบริการ ในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

การวิเคราะหขอมูลทรัพยากร 
เราควรวิเคราะหจํานวน และการจัดสรรทรัพยากรดานบุคคล สถานที่และวัสดุอุปกรณรวมทั้งยา ในกิจกรรม

ของโรงพยาบาลทุกๆกิจกรรม เพื่อใหสามารถบริหารทรัพยากรใหมีประสิทธิภาพมากที่สุด เพราะทรัพยากรทุกดานมี

จํากัด หากไมวิเคราะหขอมูลใหดี ก็อาจไมรูวากําลังใชทรัพยากรบางอยางโดยสูญเปลา ตัวอยางการวิเคราะหขอมูล

ทรัพยากร ไดแก 

- จํานวน และสัดสวน แพทย พยาบาล เภสัชกร และบุคลากรอ่ืนๆ 

- จํานวน และสัดสวนยา เวชภัณฑ นํ้ายา วัสดุตางๆที่ใช รวมถึงการส่ังซ้ือและจัดเก็บ 

- จํานวนหองตรวจ จํานวนเตียงผูปวย จํานวนหองผาตัด อัตราการครองเตียง 

- เวลาที่ใชในการตรวจ การผาตัด การเจาะเลือด การตรวจเอ็กซเรย 
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- เวลาที่วางในตารางนัดตรวจ คิวนัด การจัดสัดสวนการนัด 

- จํานวนและสัดสวนการสูญเสียทรัพยากรดานตางๆ เชน เวลาที่ผูปวยไมมาตามนัด 

- แนวโนมการเปล่ียนแปลงจํานวน และสัดสวนการใชทรัพยากรตางๆ ในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

การวิเคราะหขอมูลการบริหาร 
ผูบริหารโรงพยาบาล ตองมีขอมูลที่ดีเพื่อชวยในการคิดและการตัดสินใจ โดยตองเปนขอมูลที่ถูกตอง เชื่อถือได 

และทันสมัย ขอมูลสนับสนุนการบริหารมักเปนขอมูลที่ตองวิเคราะหไวลวงหนา จึงควรคิดวิธีการวิเคราะหไวกอนที่

ผูบริหารจะเรียกใช เพื่อใหไดขอมูลทันตามที่ผูบริหารตองการ ตัวอยางการวิเคราะหขอมูลการบริหารไดแก 

- ตนทุนการรักษาผูปวยนอก ผูปวยใน ตนทุนรายโรค 

- คาใชจายในการซ้ือยา วัสดุ อุปกรณ คาสาธารณูปโภค 

- รายรับ และรายไดตางๆของโรงพยาบาล 

- จํานวนและสัดสวนคนทํางานตามจุดตางๆ การจัดเวร  

- อัตราการลาออกของแพทย พยาบาล บุคลากรตางๆ 

- ผลการดําเนินการตามตัวชี้วัดตางๆ 

- แนวโนมการเปล่ียนแปลงลักษณะขอมูลบริหาร ในรอบ 6 เดือน 1 ป 3 ป 5 ป 
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บทที่ 2 
การจัดเตรียม ตรวจสอบ และแกไขคุณภาพขอมูลกอนนําเขาคลังขอมูล 
 

คลังขอมูลจะตองเปนแหลงขอมูลที่ถูกตอง แมนยําและเชื่อถือได ดังน้ัน ขั้นตอนที่สําคัญกอนสรางคลังขอมูล 

คือการจัดเตรียม ตรวจสอบและแกไขคุณภาพขอมูลกอนนําเขาคลังขอมูล โดยผูสรางคลังขอมูลจะตองจัดเตรียมขอมูลมี

ลักษณะรูปแบบฐานขอมูลที่เหมาะสม หรือถาดึงขอมูลออกมาจากระบบฐานขอมูลขององคกรก็จะตองตรวจสอบขอมูลที่

ดึงออกมาวาลักษณะที่เหมาะสมหรือไม หากพอวาขอมูลที่ลักษณะที่ไมเหมาะสม ก็ตองลงมือแกไขขอมูลใหมีลักษณะที่

เหมาะสมกอนนําเขาคลังขอมูล 

 การจัดเตรียมและตรวจสอบขอมูลใหอยูในลักษณะที่เหมาะสม อาจกลาวไดวาเปนการตรวจลักษณะขอมูลให

อยูรูปแบบฐานขอมูลที่เหมาะสมน่ันเอง 

 

ลักษณะขอมูลในรูปแบบฐานขอมูลที่เหมาะสม 
 ขอมูลที่จัดเก็บในรูปแบบฐานขอมูลที่ดี จะตองมีลักษณะดังตอไปน้ี 

1. เปนขอมูลที่อยูในรูปแบบตาราง โดยตารางน้ีจะตองมีบรรทัดแรกสุดเปนคําบรรยายลักษณะของขอมูลที่เก็บ

ไวในแตละชอง พื้นที่เหนือตารางตองไมเปนแถววางหรือมีคําบรรยายใดๆอยูเหน่ือแถวที่เปนคําบรรยาย

ลักษณะขอมูล 

2. ขอมูลในแถวที่อยูถัดจากบรรทัดแรกลงมาทั้งหมดเปนขอมูลแตละรายการ โดยตองไมมีบรรทัดวางแทรกอยู

ในรายการเหลาน้ี 

3. ตารางขอมูลในแตละชองควรเก็บขอมูลแตละเรื่องแยกออกจากกัน เชน แยกขอมูล คํานําหนาเก็บไวชองแรก 

ชื่อเก็บไวในชองที่ 2 และนามสกุลเก็บไวในชองที่ 3 ไมควรเก็บคํานําหนา ชื่อ นามสกุลไวในชองเดียวกัน 

4. คําบรรยายลักษณะขอมูลแตในละชองตองเปนคําที่ไมซํ้ากัน ควรเปนภาษาอังกฤษและไมมีการเวนวรรค

ระหวางคํา 

5. ทุกๆบรรทัดของตารางตองมีจํานวนชองเก็บขอมูลเทากันเสมอ 

6. ไมควรมีชองวางในแตละรายการ ถาไมมีขอมูล ควรบันทึกสัญลักษณหรือคําบรรยายใหทราบวาไมมีขอมูล 

 

ลักษณะขอมูลที่จัดเก็บอยางไมเหมาะสม 
 ขอมูลที่จัดเก็บอยางไมเหมาะสมมีหลายแบบ ที่พบบอยๆ ไดแก 

ก. เก็บขอมูลรวมไวในชองเดียวกัน ทั้งที่ควรแยกเก็บไวแตละชอง เชน เก็บวันที่เริ่มงานและวันที่ส้ินสุดงานไวใน

ชองเดียวกัน หรือ เก็บ คํานําหนา ชื่อ นามสกุลไวในชองเดียวกัน 

ข. เก็บขอมูลในรูปแบบที่ไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล เชน เก็บวันที่ เดือน ป ไวในรูปแบบ

ขอความ หรือใชป พ.ศ. แทน ป ค.ศ. เก็บจํานวนตัวเลขในรูปแบบขอความ 

ค. แยกเก็บขอมูลไวหลายตาราง ทั้งที่สามารถเก็บไวในตารางเดียวกันได 
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การแกไขขอมูลที่จัดเก็บอยางไมเหมาะสม 
 การแกไขขอมูลที่จัดเก็บอยางไมเหมาะสม ควรใชโปรแกรมจัดการขอมูลชวย เชน โปรแกรม excel [3] 

สามารถชวยแกไขชอมูลได เพราะสามารถบันทึกสูตร หรือ ฟงกชั่นเพื่อชวยแกไขขอมูลได ดังกรณีตางๆเหลาน้ี 

 

ตัวอยางการแกไข กรณี เก็บขอมูลรวมไวในชองเดียวกันท้ังท่ีควรแยกเก็บไวแตละชอง 

 ขอมูลลักษณะน้ี มักมีขอมูลหลายประเภทอยูในชองเดียวกัน ดังตัวอยางในภาพที่ 2.1 

 

การเก็บขอมูลไวชองเดียวกัน 

(ลักษณะท่ีผิดพลาด) 

การแยกเก็บขอมูลไวแตละชอง 

(ลักษณะท่ีถูกตอง) 

ชื่อ-นามสกุล คํานําหนา ชื่อ นามสกุล 

นายเดนดวง รักษาความสุข นาย เดนดวง รักษาความสุข 

นางสาวสุขตา สุขใจ นางสาว สุขตา สุขใจ 

นางสะอาด เย็นชื่น นาง สะอาด เย็นชื่น 

 

ภาพท่ี 2.1 การเก็บขอมูลคํานําหนา ช่ือ นามสกุล ไวในชองเดียวกัน 

 

แบบฝกหัด 2.1 การใช Excel แกไขขอมูล คํานําหนา ช่ือ นามสกุล ท่ีเก็บไวในชองเดียวกัน ใหไปอยูแตละชอง 

 

 เปดไฟลแบบฝกหัด Ex2.1 จะไดขอมูลตัวอยางดังน้ี 

 
 

 เพิ่มคอลัมภเพื่อปฏิบัติการระบุแยกคํานําหนาเปน 3 ประเภทในชอง B1, C1, D1 ดังน้ี 
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ใสสูตรในชอง B2, C2, D2 แลว copy สูตร ลงไปในบรรทัดที่ 3-4 ดังน้ี 

ชอง สูตร คัดลอกไปยัง 

B2 =FIND("นางสาว",A2) B3:B4 

C2 =FIND("นาย",A2) C3:C4 

D2 =FIND("นาง",A2) D3:D4 

 

 

 เม่ือดําเนินการเสร็จแลวจะไดผลลัพธดังน้ี 

 
 

 สูตรใน คอลัมภ B ใชคนหาวาในคอลัมภ A ของแตละรายการมีคําวา “นางสาว” อยูหรือไม ถามีคําวา 

“นางสาว” อยูจะไดผลลัพธการคนหาเปนเลข 1 แตถาไมมี โปรแกรม Excel จะแสดงความผิดพลาด เปนขอความ 

#VALUE! แสดงวาไมสามารถคนหาคําทีกําหนดได ผลลัพธในคอลัมภ C และ D จึงไดผลในทํานองเดียวกัน 

  

ตอไปใหเพิ่มคอลัมภเพื่อปฏิบัติการสรุปคํานําหนาเปน 3 ประเภทในชอง E1, F1, G1 ดังน้ี 

 
 

 Copy ขอมูลจากชวง B2 ถึง D4 แลวเลือกคําส่ัง Paste Special ในชอง E1 ดังน้ี 
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 เลือกวางเฉพาะขอมูล (Values) จากกรอบ Paste Special ดังน้ี 

 

 
 

 

 ขอมูลจากชวง B2 ถึง D4 จะมาอยูในชวง E2 ถึง G4 ดังน้ี 
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เลือกชวงขอมูลในคอลัมภ E, F, G แลวเลือกคําส่ัง Replace ใหแทนคา #VALUE! ดวยชองวาง ดังน้ี 

 
 

  

 

เม่ือ Replace เสร็จแลว จะไดผลลัพธดังน้ี 

 
 

 เพิ่มคอลัมภ H อีกคอลัมภหน่ึง เพื่อแยกคํานําหนา ออกมา ดังน้ี 

 
 

 พิมพสูตรในชอง H2 แลว copy สูตรลงไปในชอง H3, H4  ดังน้ี 

ชอง สูตร คัดลอกไปยัง 

H2 =IF(G2,(IF(E2,"นางสาว","นาง")),"นาย") H3:H4 

 

 สูตรดังกลาวขางตน จะตรวจสอบขอมูลวาคํานําหนามีคําวา “นาง” อยูหรือไม ถาไมใช จะเปนนาย แตถามีคํา

วา นาง ก็จะตรวจสอบอีกครั้งวาเปนนางสาวหรือไม ผลลัพธที่ไดเปนดังน้ี  
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 สุดทายเพิ่มคอลัมภชื่อและนามสกุลในคอลัมภ I ชือ่ในคอลัมภ J และนามสกุลในคอลัมภ K แลวใสสูตรดังน้ี 

ชอง สูตร คัดลอกไปยัง 

I2 =SUBSTITUTE(A2,H2,"") I3:I4 
J2 =LEFT(I2,FIND(" ",I2)) J3:J4 
K2 =RIGHT(I2,LEN(I2)-FIND(" ",I2)) K3:K4 
 

 

 

 

 

 ผลลัพธที่ไดเปนดังภาพตอไปน้ี 

 
 

 สุดทาย เราจะไดคอลัมภคํานําหนา ชื่อ นามสกุล แยกออกมาเปนคนละคอลัมภ สามารถนําเขาคลังขอมูลได

ตอไป 

 

การแกไข กรณี เก็บขอมูลในรูปแบบท่ีไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล 

 ขอมูลลักษณะน้ี มักจัดเก็บในรูปแบบที่ไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล ดังตัวอยางในภาพที่ 

2.2 

 

รูปแบบท่ีผิดพลาด ประเภทขอมูล รูปแบบท่ีถูกตอง 

15 มีนาคม 2556, 15/3/2556, 15-3-2556 วันที่ 15 มีนาคม 2013, 15/3/2013, 15-มี.ค.-

2013 

9.30 น. , 15.29.08 เวลา 9:30 น. , 15:29:08 

 

ภาพท่ี 2.2 การเก็บขอมูลในรูปแบบท่ีไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล 
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บทที่ 3  
การนําเขาขอมูลและการจัดโครงสรางพื้นฐานคลังขอมูล 

 
เม่ือจัดเตรียมและตรวจสอบขอมูลใหอยูในลักษณะที่เหมาะสมแลว ขั้นตอนตอไปคือการนําขอมูลเขาสู

คลังขอมูล ในที่น้ีจะใชโปรแกรมที่สรางคลังขอมูลและนําเขาขอมูลชื่อ Qlikview 

 โปรแกรม Qlikview เปนโปรแกรมที่บริษัท Qliktech International พัฒนาขึ้น เพื่อใชวิเคราะห

ขอมูลและนําเสนอขอมูล ซ่ึงมีหลาย version เราสามารถ download version ที่ใหทดลองใชงานไดที่ 

http://www.qlikview.com/us/explore/experience/free-download [4] ซ่ึงจะเปน version ที่

ใหใชงานไดฟรี โดยมีขอจํากัดคือไมสามารถนําขอมูลไปใชทีเครื่องอ่ืนได 

 เราจะทดลองใชโปรแกรม Qlikview พิจารณาลักษณะขอมูลตัวผูปวย โดยเริ่มจากการนําขอมูลผูปวยเขาสู

โปรแกรม ตามขั้นตอนดังน้ี 

 
ขั้นที่ 1 เลือกเมนูและคําส่ังตามลําดับดังน้ี (กรณีน้ีจัดเตรียมขอมูลโดยใช excel) 

 File  New 
 จะปรากฎ Dialog box ดังตอไปน้ี 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



13 
 

ขั้นที่ 2 กดปุม Browse เพื่อ ไปยังตํ าแหนงที่ เ ก็บขอ มูล ในตัวอยาง น้ี น้ีจะใชขอมูลจากไฟล 

admission.xlsx  เลือก File ชื่อ admission แลวกดปุม Open 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เม่ือเลือกแลวชือ่ไฟลจะเขามาอยูในชอง File Path: เสร็จแลวกดปุม Next step ดานลางขวา 
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เม่ือกดปุม Next step จะปรากฏ หนาตาง Step 2 ใหกดปุมเลือก Use column heads from 

data file บริเวณกลางหนาจอ ดังภาพดานลาง 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

ขั้นที่ 3 กดปุม Next step จะมี Dialog box ขึ้นใหตั้งชื่อ File ของ Qlikview ในที่น้ีตั้งชื่อเปน 

HDC เสร็จแลวกดปุม Save 
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 กดปุม Next ไปขั้นตอนที่ 4 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นที่ 4 Qlickview จะใหเลือกวาจะสราง Chart แบบใด ใหเลือก Bar chart แลวกดปุม Next 

step 
ขั้นที่ 5 Qlickview จะใหตัวแปรที่จะแสดงผลใน แกนนอน (Dimension) หรือ แกน X ของกราฟ ให

เลือกตัวแปรที่ตองการสรางเปนกราฟแทงตางๆบนแกน X ในที่น้ีเลือกตัวแปร WARDADMIT เพื่อสรางกราฟแสดง

แผนกที่รับผูปวย สําหรับแกน Y หรือ Expression เลือก Count the number of และ AN เพื่อใหนับ

จํานวนผูปวย แลวกดปุม Next step 
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ขั้นที่ 6 Qlickview จะถามถึง object ที่ตองการสรางเพิ่ม ใหกดปุมเลือก Listboxes แลวเลือกฟลด 

WARDADMIT ในชอง Choose fields แลวกดปุม Create 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
\ 
 
 
 
 โปรแกรม Qlikview จะสราง Object พื้นฐานมาใหดังภาพดานลาง 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
กลุม Object พื้นฐานประกอบดวย กราฟแทงแสดงผลการนับจํานวนผูปวยจําแนกตามรหัสแผนกที่รับไว

รักษาเรียงตามจํานวนผูปวยจากมากไปนอย นอกจากน้ัน ยังสราง List Box ที่มีชื่อวา WARDADMIT, สราง 

Current Selections Box ที่ใชแสดงสถานการณเลือกปจจุบัน และ Search Box อยูเปนกลุมดานซายบน

ของหนาจอแสดงผล  

ใหกดปุม Save เพื่อบันทึกผลงานขั้นตน 
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 เราสามารถปรับเปล่ียนลักษณะของกราฟแทงน้ีไดหลายแบบ โดยการคลิกขวาที่รูปกราฟจะมีเมนูขึ้นมาดังน้ี 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 เลือกรายการแรกในเมนู คือ Properties เพื่อปรับเปล่ียนรูปแบบของ กราฟ 

 
 
 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 จะปรากฏ Dialog box ชื่อ Chart properties ขึ้นมา ใน Tab General ใหตั้งชื่อในชอง 

Window Title ดานบนซายสุดวา “จํานวนผูปวยจําแนกตามแผนกที่รับไวรักษา” แลวกดปุม Apply ดานลาง 
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 ตอไปใหกดเลือก Tab ชื่อ Expressions แลวกดเลือก Values on Data Points ดานลาง ดัง

ภาพ 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 เสร็จแลวกดปุม Apply และ OK จะพบวากราฟมีรายละเอียดเพิ่มเติมดังภาพตอไป 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

กดเลอืก Values on Data 

Points เพืÉอแสดงค่าทีÉ

นบัได้ 
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 กราฟจะแสดงจํานวนยอดผูปวยที่นับไดในแตละเพศ โดยในขณะน้ีกราฟแทงจะเรียงตามจํานวนที่มากไลลงไป

จํานวนที่นอย หากตองการใหแสดงกราฟแทงตามรหัสเพศ โดยใหแสดงผลเพศชาย (SEX =1) มากอนสามารถปรับ

โดยคลิกขวาเรียก Dialog box Chart Properties แลวเลือก Tab Sort ขึ้นมาแกไขดังน้ี 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 ยกเลิกการเลือก Y-value แลวเลือก เลือก Sort by .. Text ซ่ึงจะเปนการเรียงตามลําดับอักษร แลวกด

ปุม OK จะไดผลลัพธคือ 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 ตอไป สราง Object ใหม เรียกวา Table Box โดยเลือก เมนู Object => New Sheet Object 

=> Table Box  ดังน้ี 
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 จะปรากฏ Dialog box  ชื่อ New Table Box ดังน้ี 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 ในชอง Title พิมพชื่อตารางเปน “รายการผูปวย” กดปุม Add All ตรงกลาง แลว จะไดผลดังน้ี 
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 กดปุม Load Order ทางดานขวาของกรอบโตตอบ แลวกดปุม OK จะไดตารางแสดงรายการผูปวยดังน้ี 
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ตารางน้ีจะเชื่อมโยงความสัมพันธกับ กราฟแทง และ List box รายการเพศโดยอัตโนมัติ ถาเราคลิกเลือกที่

รายการใดๆ หนาตางทั้งหมดจะแสดงขอมูลที่สัมพันธกับรายการที่เราเลือก เชน ถาคลิกที่กราฟแทงแผนกที่เปนรหัส 

100 จะไดรายการของผูปวยทกุรายที่รับเขาไวรักษาในแผนกน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ลักษณะขอมูลในรูปแบบฐานขอมูลที่เหมาะสม 

 ขอมูลที่จัดเก็บในรูปแบบฐานขอมูลที่ดี จะตองมีลักษณะดังตอไปน้ี 

 
 
 
 
 
 

การจัดโครงสรางพ้ืนฐานของคลังขอมลู 

 โครงสรางพื้นฐานของคลังขอมูล จะประกอบไปดวยสวนตางๆทีสํ่าคัญดังตอไปน้ี 

1. ขอมูลที่นําเขาไปอยูในคลังขอมูล โดยอยางนอยจะตองมีขอมูล 1 ตาราง 

2. ตารางแสดงขอมูลบางสวนหรือขอมูลทั้งหมดที่อยูในคลังขอมูล 

3. กราฟแสดงลักษณะของขอมูลในรูปแบบตางๆ 

4. กลองแสดงตัวแปรและคาของตัวแปรทั้งหมด (List Box or Multi Box) 

5. กลองแสดงสถานะการเลือกดูขอมูล (Current Selection Box) 

6. เครื่องมือชวยอ่ืนๆ เชน กลองคนหา (Search Box) 

 
การดําเนินการในสวนที่ผานมา ในใชโปรแกรม Qlikview สรางคลังขอมูลโดยไดสวนที่สําคัญ รายการที่ 1-6 

แลว  
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 กลองแสดงสถานะ Current Selections เปนเครื่องมือที่ใชตรวจสอบรายการที่เลือกอยูในปจจุบัน การ

สรางหนาตางแสดงสถานะ Current Selection ทําไดโดยเลือก เมนู Object => New Sheet Object => 

Current Selection Box.. ดังน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 เม่ือเลือก Current Selections Box.. จะได Dialog Box ดังน้ี 
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 กดปุม OK จะไดหนาตางใหมชื่อ Current Selections ใหจัดตําแหนงใหเหมาะสม 

 
 
 
 
 
 
 
 
 
 
 
 
 
อยางไรก็ตาม เรามี Current Selections box เดิมอยูแลว สามารถลบทิ้งไปได หน่ึงอัน โดย คลิกขวาที่ 

Current Selections box อันใดอันหน่ึงแลวเลือก รายการ Remove ดังภาพดานลาง 

 

 
 
 หนาตาง Current Selections น้ีจะแสดงการเลือกขอมูลที่ผูใชกําลังเลือกดูอยู เชน ในภาพดานบนน้ี ผูใช

กําลังเลือกขอมูลเฉพาะผูปวยเพศหญิง ในชองจึงแสดงวามีการเลือกขอมูลผูปวยเพศหญิง หากตองการยกเลิกการเลือกให

กดปุมรูปยางลบ ในหนาตาง Current Selections หรือกดปุม Clear ใน Tool bar ดานบนของโปรแกรม 

Qlikview 
 

 
 
 
ปุม Clear ใชยกเลิก การเลือกทั้งหมด สวนปุม Back ใชยกเลิกการเลือกครั้งลาสุด 1 ครั้ง หรือ ถอย

กลับไปสถานะกอนหนา เหมือนปุมยอนกลับใน Web Browser 
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การสรางกลองคนหาทําไดโดย เลือก เมนู Object => New Sheet Object => Search Object.. 

ดังน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
จะปรากฏกลองโตตอบดังน้ี 
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ใหกําหนดวา กลองคนหาจะใชคนหาใน Fields ใดบาง ถาตองการใหคนหาไดทุก Fields ใหเลือก All 

Fields แลวกดปุม OK จะไดกลองคนหาดังน้ี 

 
 
 
 
ลองพิมพขอความใดๆเขาไปในกลองคนหา กลองคนหาจะแสดงรายการขอมูลที่มีขอความลักษณะน้ันอยูดังน้ี 
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บทที่ 4  
การวิเคราะหขอมูลในคลังขอมูล 

 
การวิเคราะหขอมูลคือการเปล่ียนขอมูลดิบใหกลายเปนสารสนเทศ หมายถึงการทําใหขอมูลมีความหมายมาก

ขึ้น ทําใหเห็นภาพดานตางๆของขอมูล เพื่อใหสามารถนําสารสนเทศไปใชประโยชนในดานตางๆไดมากขึ้น การวิเคราะห

ขอมูลในคลังขอมูลที่สรางจากโปรแกรม Qlikview น้ี จะมีขั้นตอนที่สําคัญดังน้ี 

1. การทําใหขอมูลมองเห็นได (Data Visualization) 

2. การใชการคํานวณเพื่อวิเคราะหความหมายดานตางๆของขอมูล 

3. การนําเสนอขอมูลที่วิเคราะหแลวในรูปแบบสารสนเทศเพื่อนําไปใชประโยชน 

 

การทําใหขอมูลมองเห็นได  
 การทําใหขอมูลมองเห็นได คือ การนําเสนอขอมูลในรูปแบบกราฟ หรือทําใหเปนภาพ แผนภูมิ แผนผัง มีการ

จัดรูปแบบใหเปนระเบียบเรียบรอย และเขาใจงาย ซ่ึงการทําใหขอมูลมองเห็นจะมีประโยชนอยางยิ่งในการส่ือสาร เพราะ

ทําใหผูรับขอมูลเขาใจความหมายของขอมูลไดโดยงาย ปจจุบัน มีองคกรหลายแหงในระดับนานาชาติ เชน บริษัทผลิต

รถยนตโตโยตา ใชการทําขอมูลมองเห็นได เปนเครื่องมือสําหรับการบริหารจัดการและการปฏิรูปงานตางๆ 

เราสามารถใชโปรแกรม Qlikview ทําขอมูลใหมองเห็นไดโดยงาย ในลักษณะตางๆดังตอไปน้ี 

 
การสรางกราฟแทง 

 กอนเริ่มสรางกราฟ ควรปรับแตง toolbar ของโปรแกรม Qlikview เพื่อเพิ่มแถบเครื่องมือในการสราง

วัตถุตางๆ โดยเลือกเมนู View => Toolbars => Design ดังน้ี 
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คําส่ังจะเปดแถบเครื่องมือขึ้นมา เพิ่มขึ้นอีก 1 แถบดังภาพดานลาง 

เราสามารถใชแถบเครื่องมือที่เพิ่มขึ้นมาน้ี เพิ่มวัตถุตางๆและจัดรูปแบบคลังขอมูลเขาเราไดโดยสะดวกงายดาย 

เริ่มจากการเพิ่มกราฟโดยกดปุม  แลวใสชื่อในชอง Window Title เปน “จํานวนผูปวยจําแนกตามโรงพยาบาลที่

รักษา” ดังน้ี 

เลือก Chart Type เปนกราฟแทง (รูปแรกสุด) แลวกดปุม Next จะไดกรอบโตตอบ Dimensions 

ขึ้นมา ใหเลือก HOSPCODE จากชอง Available Fields/Groups ที่อยูดานซายบนสุดแลวกดปุม Add ดัง

ภาพตอไปนี้ 
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กดปุม Next ไปสูขั้นตอนตอไป 

ในกรอบโตตอบ Edit Expression เลือกคําส่ัง Total count จาก combo box ชื่อ 

Aggregation และเลือก AN ใน combo box ชื่อ Field แลว check เครื่องหมายถูกใน check box ชื่อ 

Distinct กดปุม Paste จะไดภาพดานลาง 

เลือก Aggreation เปน Total count เลือก AN ในชอง Field แลวคลิกเลือก Distinct ในชอง check 

box ดังภาพดานลาง 

 
กดปุม OK ไปสูขั้นตอนตอไป ในกรอบโตตอบ Expressions เลือก check box ชื่อ Values on 

Data Points จะไดภาพดานลาง 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Select Total Count 

2. Select AN 

3. Select Distinct 
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กดปุม Finish แลวจะไดกราฟแทงดังภาพดานลางน้ี 

 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
การสรางกราฟวงกลม 

กดปุม  แลวใสชื่อในชอง Window Title เปน “จํานวนผูปวยจําแนกตาม Discharge Status” 

แลวกดปุมเลือกประเภทของกราฟเปนกราฟวงกลม           ดังน้ี 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
กดปุม Next จะไดกรอบโตตอบ Dimensions ขึ้นมา ใหเลือก DISCHSTATUS จากชอง 

Available Fields/Groups ที่อยูดานซายบนสุดแลวกดปุม Add ดังภาพตอไปน้ี 
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กดปุม Next ไปสูขั้นตอนตอไป 

 
 
เลือก Aggreation เปน Total count เลือก AN ในชอง Field แลวคลิกเลือก Distinct ในชอง check 

box ดังภาพดานลาง 

 
 
กดปุม OK ไปสูขั้นตอนตอไป ในกรอบโตตอบ Expressions เลือก check box ชื่อ Values on 

Data Points จะไดภาพตอไป 

 
 
 
 

1. Select Total Count 

2. Select AN 

3. Select Distinct 
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กดปุม Finish แลวจะไดกราฟวงกลมดังภาพดานลางน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เราสามารถใชหลักการเดียวกันน้ี ในการสรางกราฟรูปแบบอ่ืน เชน กราฟรูปกรวย (Funnel Chart) กราฟ

เสน (Line Chart) หรือกราฟอ่ืนๆ 

 
ฝกฝนเพิ่มเติม 

ลองสรางกราฟรูปกรวย แสดงจํานวนผูปวยจําแนกตามสิทธิการรักษา 
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บทที่ 5  
การเช่ือมโยงตารางขอมูลหลายตารางเขาหากัน 

 
คลังขอมูลจะเปนแหลงรวบรวมขอมูลของหนวยงานเพื่อใชบริการขอมูล ดังน้ันในคลังขอมูลจะมีขอมูลอยู

มากมาย ขอมูลมักจะเก็บอยูในตารางหลายตาราง เราจะตองเชื่อมโยงตารางเหลาน้ีเขาหากัน เพื่อใหการคนหาและ

วิเคราะหขอมูลเปนไปอยางมีประสิทธิภาพ 

ในบทน้ีจะเปนการฝกเชื่อมโยงขอมูลผูปวยเขากับขอมูลอ่ืนๆ เชน ขอมูลลักษณะทั่วไปของผูปวย หรือ ขอมูล

รหัสกลุมโรค ICD ของผูปวย เปนตน 
 
การเช่ือมโยงขอมูลผูปวยเขากับขอมูลการรับผูปวยเขารักษาในโรงพยาบาล 

ในบทน้ื เราจะใชชุดขอมูลจาก 43 แฟมมาตรฐานที่กําหนดโดยสํานักนโยบายและยุทธศาสตร กระทรวง

สาธารณสุข มาเชื่อมโยงกันในคลังขอมูล โดยจะเริ่มจากการนําเขาและเชื่อมโยงแฟม  Admission กับแฟม Person 

เราไดนําเขาแฟม Admission เขามาแลว โดยแฟม Admission มีโครงสรางขอมูลดังน้ี 

 

NAME 

(3) 

DESCRIPTION 

(4) 
PK(5) TYPE(6) WIDTH(7) 

HOSPCODE  รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y  C 5 

PID   ทะเบียนของบคุคลทีÉมาขึ Êนทะเบียนในสถานบริการนั Êนๆ ใช้สําหรับ

เชืÉอมโยงหาตวับคุคลในแฟ้มอืÉน ๆ (สามารถกําหนดได้

ตั Êงแต่ 1-15 หลกั) 

Y  C 15 

SEQ   ลําดบัทีÉของการบริการทีÉกําหนดโดยโปรแกรมเรียงลําดบัโดยไม่ซํ Êา

กนั สําหรับการมารับบริการแต่ละครั Êง (visit) 

  C 16 

AN เลขทีÉผู้ป่วยใน (AN) Y  C 9 

DATETIME_ADMIT วนัเดือนปีและเวลาทีÉรับผู้ ป่วยไว้ในโรงพยาบาล กําหนดเป็น ค.ศ.

(YYYYMMDDHHMMSS) 

  DT 14 

WARDADMIT รหสัแผนกทีÉรับผู้ ป่วย อ้างอิงตามมาตรฐาน สนย.   C 5 

INSTYPE รหสัสทิธิมาตรฐาน ทีÉใช้ในการมารับบริการ (สทิธิหลกัในการ 

admit ครั Êงนั Êน) 

  C 4 

TYPEIN 1 = มารับบริการเอง, 2 = มารับบริการตามนดัหมาย, 3 = ได้รับ

การสง่ต่อจากสถานพยาบาลอืÉน, 4 = ได้รับการสง่ตวั

จากบริการ EMS 

  C 1 

CAUSEIN 1 = เพืÉอการวนิจิฉยัและรักษา, 2 = เพืÉอการวนิจิฉยั, 3 = เพืÉอการ

รักษาต่อเนืÉอง, 4 = เพืÉอการดูแลต่อใกล้บ้าน, 5 = ตาม

ความต้องการผู้ป่วย 

  C 1 
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NAME 

(3) 

DESCRIPTION 

(4) 

PK(5) TYPE(6) WIDTH(7) 

ADMITWEIGHT นํ Êาหนกัผู้ป่วยแรกรับ (กิโลกรัม) จุดทศนยิม 1 ตําแหนง่   N 5 

ADMITHEIGHT สว่นสงูผู้ป่วยแรกรับ (ซ.ม.)   N 3 

DATETIME_DISCH วนัเดือนปีและเวลาทีÉจําหนา่ยผู้ป่วย กําหนดเป็น ค.ศ.

(YYYYMMDDHHMMSS) 

  DT 14 

WARDDISCH รหสัแผนกทีÉจําหนา่ยผู้ป่วย อ้างอิงตามมาตรฐาน สนย.   C 5 

DISCHSTATUS รหสัสถานภาพการจําหนา่ยผู้ป่วย   C 1 

DISCHTYPE รหสัชนดิการจําหนา่ยผู้ ป่วย   C 1 

REFEROUTHOSP รหสัสถานพยาบาลทีÉสง่ผู้ป่วยไปรักษาต่อ   C 5 

CAUSEOUT 1 = เพืÉอการวนิจิฉยัและรักษา, 2 = เพืÉอการวนิจิฉยั, 3 = เพืÉอการ

รักษาต่อเนืÉอง, 4 = เพืÉอการดูแลต่อใกล้บ้าน, 5 = ตาม

ความต้องการผู้ป่วย 

  C 1 

COST ราคาทนุซึÉงรวมค่ายาและเวชภัณฑ์ทั Êงหมดรวมทั Êงค่าบริการ

ทางการแพทย์ (รวมจุดทศนยิมและเลขหลงัจุด 2 

ตําแหนง่) 

  N 11 

PRICE ราคาขายซึÉงรวมค่ายาและเวชภณัฑ์ ทั Êงหมดรวมทั Êงค่าบริการ

ทางการแพทย์ (รวมจุดทศนยิมและเลขหลงัจุด 2 

ตําแหนง่) 

  N 11 

PAYPRICE จํานวนเงินทีÉเรียกเก็บ เนืÉองจากเป็นคา่ใช้จ่ายทีÉเบกิไม่ได้ (รวมจุด

ทศนยิมและเลขหลงัจุด 2 ตําแหนง่) โดยถ้าไม่มีการเรียก

เก็บให้ใสเ่ลขศูนย์ 

  N 11 

ACTUALPAY จํานวนเงินทีÉจ่ายจริง ถ้าไม่มีการจ่ายให้ใสเ่ลขศูนย์   N 11 

PROVIDER เลขทีÉผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํ Êากนัในสถานพยาบาล

เดียวกนั (หมอผู้รบัผดิชอบคนไข้หลกั) 

  C 15 

D_UPDATE วนัทีÉเพิÉมและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัÉวโมง

นาทีวนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสต

ศกัราช 

  DT 14 
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แฟม Person เปนแฟมที่เก็บรายละเอียดขอมูลผูปวยแตละราย มีโครงสรางขอมูลดังน้ี 

NAME 

(3) 

DESCRIPTION 

(4) 
PK(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y  C 5 

CID เลขประจําตวัประชาชน ตามกรมการปกครองกําหนดเป็นรหสัประจําตัว

บคุคล 

  C 13 

PID ทะเบียนของบคุคลทีÉมาขึ Êนทะเบียนในสถานบริการนั Êนๆ ใช้สําหรับ

เชืÉอมโยงหาตวับคุคลในแฟ้มอืÉน ๆ (สามารถกําหนดได้ตั Êงแต่ 1-

15 หลกั)(program generate) 

Y C 15 

HID รหสับ้านทีÉกําหนดโดยโปรแกรมจากแฟ้ม HOME และรหสันี Êจะซํ Êากนัได้

หากบคุคลอาศยัอยู่ในหลงัคาเรือนเดียวกนั อ้างอิงเพืÉอค้นหา

บ้านในแฟ้ม HOME (หลงัคาเรือนในเขตรับผดิชอบ) กรณีทีÉ

อาศยัในเขตรบัผดิชอบ 

  C 14 

PRENAME คํานําหน้าชืÉอ อ้างอิงมาตรฐานตามกรมการปกครอง   C 3 

NAME ชืÉอ   C 50 

LNAME นามสกุล   C 50 

HN 
เลขทะเบียนการมารับบริการ(สามารถกําหนดได้ตั Êงแต่ 1-15 หลกั) ใน

กรณีทีÉมีเลขทะเบียนทีÉต่างไปจาก PID 

  C 15 

SEX 1 = ชาย , 2 = หญิง   C 1 

BIRTH วนัเดือนปีเกิด กําหนดเป็น ค.ศ. (YYYYMMDD) (หากไม่ทราบวนั เดือน

ทีÉเกิด แต่ทราบ ค.ศ เกิด ให้กําหนดวนัเกิดเป็นวนัทีÉ 1 มกราคม

ของปี ค.ศ.นั Êนๆ) 

  C 8 

MSTATUS 1 = โสด, 2 = คู,่ 3 = ม่าย, 4 = หย่า, 5 = แยก, 6 = สมณะ,  9=ไม่ทราบ   C 1 

OCCUPATION_OLD รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 3 

OCCUPATION_NEW รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 4 

RACE รหสัมาตรฐานตามกรมการปกครอง   C 3 

NATION รหสัมาตรฐานตามกรมการปกครอง ถ้าไม่ทราบให้ระบ ุ999 ตาม

รหสัมาตรฐาน 

  C 3 

RELIGION รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 2 

EDUCATION รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 2 

FSTATUS 1 = เจ้าบ้าน  , 2 = ผู้อาศยั   C 1 
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NAME 

(3) 

DESCRIPTION 

(4) 
PK(5) 

TYPE 

(6) 

WIDTH 

(7) 

FATHER รหสับตัรประชาชนของบดิา   C 13 

MOTHER รหสับตัรประชาชนของมารดา   C 13 

COUPLE รหสับตัรประชาชนของคูส่มรส   C 13 

VSTATUS 1 = กํานนั ผู้ใหญ่บ้าน, 2 = อสม., 3 = แพทย์ประจําตําบล,  

4 = สมาชิกอบต., 5 = อืÉนๆ 

  C 1 

MOVEIN วนัเดือนปีทีÉย้ายเข้า ในเขตรับผดิชอบ กําหนดเป็น ค.ศ.(YYYYMMDD)   C 8 

DISCHARGE 1 = ตาย , 2 = ย้าย  , 3 = สาบสญู ,9 =ไม่จําหนา่ย   C 1 

DDISCHARGE วนัเดือนปีทีÉจําหนา่ย กําหนดเป็น ค.ศ. (YYYYMMDD)   C 8 

ABOGROUP 1 = A , 2 = B , 3 = AB , 4 = O   C 1 

RHGROUP 1 = positive , 2 = negative   C 1 

LABOR รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์      C 2 

PASSPORT เลขทีÉ passport   C 8 

TYPEAREA 1=มีชืÉออยู่ตามทะเบียนบ้านในเขตรับผดิชอบและอยู่จริง2= มีชืÉออตาม

ทะเบีบนบ้านในเขตรับผดิชอบแต่ตวัไม่อยู่จริง3= มาอาศยัอยู่ในเขต

รับผดิชอบ(ตามทะเบียนบ้านในเขตรับผดิชอบ)แต่ทะเบียนบ้านอยู่นอก

เขตรับผดิชอบ4= ทีÉอาศยัอยู่นอกเขตรับผดิชอบและทะเบียนบ้านไม่อยู่

ในเขตรับผดิชอบ เข้ามารับบริการหรือเคยอยู่ในเขตรับผดิชอบ5=มา

อาศยัในเขตรับผดิชอบแต่ไม่ได้อยู่ตามทะเบียนบ้านในเขตรับผดิชอบ 

เช่น คนเร่ร่อน ไม่มีทีÉพกัอาศยั เป็นต้น   

  C 1 

D_UPDATE วนัทีÉเพิÉมและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัÉวโมงนาที

วนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสตศกัราช 

  C 14 

 
 

กอนนําแฟม Person เขาสูคลังขอมูล ตองจัดเตรียมแฟมในรูปแบบที่เหมาะสม โดยทําเปน text file 

นามสกุล .txt หรือ.csv หรือ .xml ใหเรียบรอย 
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 การนําแฟม Person เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “Person”, ดังภาพ

หนาจอดานลาง 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
3. ใน tab Person พิมพขอความ “Person:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง 

 
 
 
 
 
 
 
 
 
 
 
4. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ Person ที่เก็บไวใน Folder ใดๆ เชนในที่น้ีอยูใน 

Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียดของไฟลดังภาพ

ดานลาง 
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4. เลือก Delimiter เปน | และเลือก Character Set เปน ภาษาไทย ดังภาพดานลาง 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. กดปุม Finish ดานลาง Qlikview จะสรางคําส่ังเพื่อใชในการนําเขาไฟลดังแสดงในภาพตอไป 
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6. กดปุม OK เพื่อปดหนาตาง Edit Script  
7. Save เพื่อบันทึกงานที่ทํามาแลว  
8. Reload ขอมูลทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน 

toolbar  
9. ตรวจสอบวามีตารางเขามาอยูในฐานขอมูลอยางครบถวนหรือไม โดยเลือก menu File => Table 

Viewer… หรือกดปุมรูป              ที่ปรากฏบน toolbar  
 
11. ถาขอมูลนําเขามาไดถูกตอง หนาตาง Table Viewer จะแสดงภาพตารางทั้งหมดที่อยูในคลังขอมูล มี

สองตารางหรือ ตาราง Admission และ Person เชื่อมโยงกัน (แสดงเสนเชื่อมโยง) โดยเลข HN ดัง

ภาพดานลาง  
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12. ถาไมพบภาพดังกลาว แสดงวาเกิดความผิดพลาดในขั้นตอนที่ผานมา ตองดําเนินการใหม โดยการเปด

หนาจอ Edit Script แลวลบขอความทั้งหมดที่อยูใน tab Person แลวดําเนินการตามขั้นตอน 3 ถึง 

11 ใหมทั้งหมด 

13. การเชื่อมโยงตารางในขณะน้ี เปนการเชื่อมโยงโดยอัตโนมัติ ที่เกิดจาก Qlikview จะเลือก Field ที่มี

ชื่อเดียวกันในตารางทั้งสองมาเชื่อมโยงกัน ดังภาพแสดงการเชื่อมโยงระหวาง 3 ฟลด  คือ 

HOSPCODE,  PID และ D_UPDATE โดยเชื่อมโยงเปน Synthetic Key ชื่อ $Syn1 แตการ

เชื่อมโยงอัตโนมัติ น้ี ไม เหมาะสมเพราะถาดูตามความเปนจริงแลว การเชื่อมโยงควรใช เฉพาะ 

HOSPCODE และ PID มาเชื่อมโยงกัน โดยไมเชื่อมโยงฟลด D_UPDATE เพราะฟลดน้ีไมไดเก็บ

ขอมูลที่จะใชเชื่อมโยงตารางได เราจึงควรแกไข Script ในหนา Main และ Person โดยการเปด

หนาจอ Edit Script และแกไขขอความ ดังตอไปน้ี 

แกไข Main ตั้งแตบรรทัดที่มีขอความ LOAD ลงไป 2 บรรทัดดังน้ี 
LOAD HOSPCODE, 
     HOSPCODE&PID AS ID,  
     SEQ,  
     AN,  
     DATETIME_ADMIT,   

….. 
 
แกไข Person รวม 2 ที่ เริ่มจากบรรทัดที่มีขอความ LOAD ลงไป 2 บรรทัดดังน้ี 

Person: 
LOAD HOSPCODE AS PSHOSPCODE,   
     CID,  
     PID, 
     HOSPCODE&PID AS ID,  
     HID,  
     PRENAME,   

….. 
และในบรรทัดที่มีขอความ D_UPDATE  ดังน้ี 

PASSPORT,  
     TYPEAREA,  
     D_UPDATE AS PSD_UPDATE 
FROM 
……  

 
14. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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การเช่ือมโยงขอมูลผูปวยเขากับขอมูลรหัส ICD 
 
ในการวิเคราะหขอมูลผูปวย เรื่องแรกที่สําคัญคือการวิเคราะหกลุมโรคที่พบในผูปวยที่ใหรหัสไวโดยใช 

International Classification of ICD โดยเราจะนําเขาขอมูลที่เก่ียวของกับ การใหรหัส ICD ของผูปวยรวม 

3 แฟม คือ DIAGNOSIS_OPD, DIAGNOSIS_IPD, PROCEDURE_OPD 

 
แฟม DIAGNOSIS_OPD เก็บขอมูลในโครงสรางขอมูลดังน้ี 

 
NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE  รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y C 5 

PID   ทะเบียนของบคุคลทีÉมาขึ Êนทะเบียนในสถานบริการนั Êนๆ ใช้สําหรับ

เชืÉอมโยงหาตวับคุคลในแฟ้มอืÉน ๆ (สามารถกําหนดได้ตั Êงแต่ 1-

15 หลกั) 

Y C 15 

SEQ   
ลําดบัทีÉของการบริการทีÉกําหนดโดยโปรแกรมเรียงลําดบัโดยไม่ซํ Êากนั 

สําหรับการมารับบริการแต่ละครั Êง (visit) 

Y C 16 

DATE_SERV วนัเดือนปีทีÉมารับบริการ กําหนดเป็น ค.ศ.(YYYYMMDD)   D 8 
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NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

DIAGTYPE 1 = PRINCIPLE DX (การวินจิฉยัโรคหลกั)  

4 = OTHER (อืÉน ๆ)  

5 = EXTERNAL CAUSE(สาเหตุภายนอก)  

6 = Additional Code (รหสัเสริม)  

7 = Morphology Code (รหสัเกีÉยวกบัเนื Êองอก) 

 C 1 

DIAGCODE   รหสัโรค ICD - 10 - TM Y C 6 

CLINIC รหสัแผนกทีÉรับบริการ อ้างอิงตามมาตรฐาน สนย.  C 5 

PROVIDER เลขทีÉผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํ Êากนัในสถานพยาบาลเดียวกัน  C 15 

D_UPDATE วนัทีÉเพิÉมและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัÉวโมงนาที

วนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสตศกัราช 

 DT 14 

 
 
การนําแฟม DIAGNOSIS_OPD เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอน

ดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “ICDOPD”, ใน 

tab ICDOPD พิมพขอความ “ICDOPD:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง 

 

 
 
3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_OPD ที่เก็บไวใน Folder ใดๆ 

เชนในทีน้ี่อยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด
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ของไฟล ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย (ในกรณีเปด text file) ดังภาพ

ตอไป 

 

 
 
4. แกไข Script ในหนา ICDOPD ใหเปนดังตอไปน้ี 

ICDOPD: 
LOAD HOSPCODE&PID AS ID,  
     HOSPCODE&PID&SEQ AS OPDID,  
     HOSPCODE AS OPDHOS,            
     DATE_SERV,  
     DIAGTYPE AS ICDOPDTYPE,  
     DIAGCODE AS ICDOPD,  
     CLINIC 
FROM 
… 

 
5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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แฟม DIAGNOSIS_IPD เก็บขอมูลในโครงสรางขอมูลดังน้ี 

 
NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE  รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y C 5 

PID   ทะเบียนของบคุคลทีÉมาขึ Êนทะเบียนในสถานบริการนั Êนๆ ใช้สําหรับ

เชืÉอมโยงหาตวับคุคลในแฟ้มอืÉน ๆ (สามารถกําหนดได้ตั Êงแต่ 1-

15 หลกั) 

Y  C 15 

AN เลขทีÉผู้ป่วยใน (AN) Y  C 9 

DATETIME_ADMIT วนัเดือนปีและเวลาทีÉรับผู้ ป่วยไว้ในโรงพยาบาล กําหนดเป็น ค.ศ.

(YYYYMMDDHHMMSS) 

  DT 14 

WARDDIAG รหสัแผนกทีÉรับผู้ ป่วย อ้างอิงตามมาตรฐาน สนย.   C 5 

DIAGTYPE 1 = PRINCIPLE DX (การวินจิฉยัโรคหลกั)  

2 = CO-MORBIDITY(การวนิจิฉยัโรคร่วม)  

3 = COMPLICATION(การวนิจิฉยัโรคแทรก)  

4 = OTHER (อืÉน ๆ)  

5 = EXTERNAL CAUSE(สาเหตุภายนอก)   

6 = Additional Code (รหสัเสริม)  

7 = Morphology Code (รหสัเกีÉยวกบัเนื Êองอก) 

  C 1 

DIAGCODE   รหสัโรค ICD - 10 - TM Y  C 6 

PROVIDER เลขทีÉผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํ Êากนัในสถานพยาบาลเดียวกัน   C 15 
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การนําแฟม DIAGNOSIS_IPD เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอน

ดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “ICDIPD”, ใน 

tab ICDIPD พิมพขอความ “ICDIPD:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ   

ขึ้นบรรทัดใหมดังภาพหนาจอดานลาง 

 

 
 
3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_IPD ที่เก็บไวใน Folder ใดๆ เชน

ในที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียดของ

ไฟล ถาเปด text file ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย หรือถาเปด 

excel file ใหตรวจสอบขอมูลใหเรียบรอย ดังภาพตอไป 
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4. แกไข Script ในหนา ICDIPD ใหเปนดังตอไปน้ี 
ICDIPD: 
LOAD HOSPCODE&PID&AN AS ANID,  
     WARDDIAG,  
     DIAGTYPE AS ICDIPDTYPE,  
     DIAGCODE AS ICDIPD 
 
FROM 
… 

  
5. แกไข Script ในหนา Main ใหเปนดังตอไปน้ี 

LOAD HOSPCODE, 
HOSPCODE&PID AS ID,  
SEQ,  
HOSPCODE&PID&AN AS ANID, 
AN,   

 ……. 
 

6. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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แฟม PROCEDURE_OPD เก็บขอมูลในโครงสรางขอมูลดังน้ี 

NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y C 5 

PID ทะเบียนของบคุคลทีÉมาขึ Êนทะเบียนในสถานบริการนั Êนๆ ใช้สําหรับ

เชืÉอมโยงหาตวับคุคลในแฟ้มอืÉน ๆ (สามารถกําหนดได้ตั Êงแต่ 1-

15 หลกั) 

Y C 15 

SEQ ลําดบัทีÉของการบริการทีÉกําหนดโดยโปรแกรมเรียงลําดบัโดยไม่ซํ Êากนั 

สําหรับการมารับบริการแต่ละครั Êง (visit) 

Y C 16 

DATE_SERV วนัเดือนปีทีÉมารับบริการ กําหนดเป็น ค.ศ.(YYYYMMDD) D 8 

CLINIC รหสัแผนกทีÉรับบริการ อ้างอิงตามมาตรฐาน สนย. C 5 

PROCEDCODE รหสัมาตรฐาน ICD-9-CM หรือ ICD-10-TM (รหสัหตัถการ) Y C 7 

SERVICEPRICE ราคาค่าบริการหตัถการ มีทศนยิม 2 ตําแหนง่ N 11 

PROVIDER เลขทีÉผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํ Êากนัในสถานพยาบาลเดียวกัน C 15 

D_UPDATE วนัทีÉเพิÉมและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัÉวโมงนาที

วนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสตศกัราช 

DT 14 

การนําแฟม PROCEDURE_OPD เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอน

ดังตอไปน้ี 

1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม ที่อยูบน 

toolbar.

2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “PROOPD”, ใน 

tab PROOPD พิมพขอความ “PROOPD:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ 

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง
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3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ PROCEDURE_OPD ที่เก็บไวใน Folder ใดๆ 

เชนในที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด 

ของไฟล ถาเปด text file ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย หรือถาเปด 

excel file ใหตรวจสอบขอมูลใหเรียบรอย ดังภาพตอไป

4. แกไข Script ในหนา PROOPD ใหเปนดังตอไปน้ี

LOAD HOSPCODE&PID&SEQ AS OPDID,
DATE_SERV AS DATEPRO,
PROCEDCODE,
SERVICEPRICE AS PROPRICE

FROM
…

5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê
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บทท่ี 6   

การนับจํานวนและการวิเคราะหสัดสวน 
 

การนับจํานวนและการวิเคราะหความถี่เปนการวิเคราะหทางสถิติขั้นพื้นฐาน เราจะเริ่มดําเนินการวิเคราะหโดย

การนับจํานวนผูปวยตามลักษณะตางๆ โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Sheet1 ใหกลายเปน Patient ดังภาพ

หนาจอดานลาง 

 

 
 
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar ดังภาพหนาจอตอไป 
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4. พิมพชื่อ “จํานวนผูปวยจําแนกตามเพศ” เขาไปในชอง Window Title ในหนาจอ General แลวเลือก

ภาพกราฟแทง (bar chart) ที่อยูในกรอบ Chart type ดังภาพตอไป แลวกดปุม Next 
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5. เลือก SEX จากชอง Available Fields/Groups แลวกดปุม Add เพื่อให SEX เขาไปอยูใน ชอง 

Used Dimensions ดังภาพดานลาง

6. กดปุม Next เพื่อเปดหนาตาง Edit Expression เลือก Total Count ในของ Aggregation แลว

เลือก AN ในชอง Field แลวคลิกเลือก Distinct ในชอง check box ดังภาพดานลาง

1. Select Total Count

2. Select ID

3. Select Distinct



53 

7. กดปุม Paste จะพบวามีชอความที่ใชแสดงคาในแกน Y ของกราฟแทง อยูในชอง Expression ดัง

ภาพดานลาง

8. กดปุม OK เพ่ือปดหนาตาง Edit Expression จะพบหนาตาง Expression ซึ่งแสดงสูตร Count 

(DISTINCT ID) อยูในชองดานบนซายและในชอง Definition ใหคลิกเลือกกลอง Value on Data 

Points ดังภาพตอไป

9. กดปุม Finish จะไดกราฟแทงที่แสดงจํานวนผูปวยจําแนกตามแผนกดังภาพตอไป
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10. กราฟแทงน้ีแสดง จํานวนผูปวยจําแนกตามเพศ 

 
ตอเปนเปนการวิเคราะหความถี่ โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

  

1. คลิกขวาที่กราฟแทงแสดงเพศผูปวยแลวเลือก menu Clone ดังภาพดานลาง   
 

 
 
2. การ Clone จะสรางกราฟแทงใหมที่เหมือนกับกราฟเดิม เราจะใชกราฟแทงใหมน้ีแสดงความถี่ของ

จํานวนผูปวยในแตละเพศ คลิกขวาที่กราฟแทงใหมแลวปรับแตง Propertites ใน tab General ตั้งชื่อ

เปน สัดสวนของผูปวยในแตละเพศ ดังภาพตอไป  
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3. ไปที่ tab Expressions แลวคลิกเลือก กลอง Relative ที่อยูตรงกลาง Tab ดังภาพดานลาง  
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4. กดปุม OK เพื่อปดหนาตาง เราจะไดกราฟแทงที่สองแสดงสัดสวนผูปวยในแตละแผนกดังภาพดานลาง 
  

 
 
 
5. ตอไปลองเปล่ียนรูปแบบของกราฟโดยการปรับแตง Properties ใช tab General แลวเปล่ียนภาพ

ของกราฟเปนกราฟวงกลมดังภาพดานลาง 
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6. กดปุม OK เพื่อปดหนาตาง เราจะไดกราฟวงกลมแสดงสัดสวนผูปวยในแตละเพศดังภาพดานลาง 
  

 
 

7. ลองขยับ mouse ให cursor ไปอยูในสวนของวงกลม จะเห็นวาสวนที่เราชี้จะขยายออกแสดงขอมูลดัง

ภาพตอไป 
  

 
 
8. เราสามารถย่อ (minimize) กราฟทั้งหมดที่อยูใน worksheet ไดโดยการกดปุมรูป _ ที่มุมบนขวา

ของกราฟ โดยถากดปุม minimize กราฟวงกลมจะพบวา กราฟวงกลมจะยุบลงเหลือแตชื่อดังภาพ

ดานลาง 
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9. ถากราฟอยูในสถานะยอ (minimize) ภาพของกราฟจะแสดงอยูที่ขอบซายขางๆชื่อของกราฟน้ัน เรา

สามารถขยายกราฟไดดวยการ doulble click กราฟน้ัน 
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บทท่ี 7   

การวิเคราะหลําดับ (Ranking Analysis) 
 
การวิเคราะหลําดับเปนการวิเคราะหทางสถิติที่ใชบอยที่สุด ตัวอยางการวิเคราะหลักษณะน้ีไดแก 

 สถิติสาเหตุการตายที่พบมากที่สุด 10 อันดับแรก 

 สถิติโรคหลัก 5 อันดับแรก 

 สถิติแผนกที่ใหบริการผูปวยมากที่สุด 7 อันดับแรก 

 
เราสามารถใช Qlikview ชวยวิเคราะหลําดับไดอยางงายดาย โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Sheet2 ใหกลายเปน Ranking 

Analysis   
  
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   

  
4. พิมพชื่อ “สถิติโรคหลัก 10 อันดับแรก” หรือ Top 10 Principal Diagnosis เขาไปในชอง 

Window Title ในหนาจอ General แลวเลือกภาพกราฟแทง (bar chart) ที่อยูในกรอบ Chart 

type ดังภาพตอไป แลวกดปุม Next 

 
5. เลือก DIAG จากชอง Available Fields/Groups แลวกดปุม Add เพื่อให ICDIPD เขาไปอยูใน

ชอง Used Dimensions ดังภาพดานลาง 

 

Prepare to Click “Edit” 
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 6. กดปุม Edit เพื่อเปดหนาตาง Edit Expression เปล่ียนขอความสูตรจากคําวา ICDIPD ให

กลายเปนคําวา IF(ICDIPDTYPE=1, ICDIPD) ดังภาพดานลาง 

  

 
 
7. กดปุม Next เพื่อเปดหนาตาง Edit Expression เลือก Total Count ในของ Aggregation แลว

เลือก ANID ในชอง Field แลวคลิกเลือก Distinct ในชอง check box ดังภาพดานลาง 

 

 
 
8. กดปุม Paste จะพบวามีชอความที่ใชแสดงคาในแกน Y ของกราฟแทง อยูในชอง Expression ดัง

ภาพดานลาง 

 

1. Select Total Count 

2. Select ANID 

3. Select Distinct 
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9. กดปุม OK เพื่อปดหนาตาง Edit Expression จะพบหนาตาง Expression ซ่ึงแสดงสูตร Count 

(DISTINCT ANID) อยูในชองดานบนซายและในชอง Definition ใหคลิกเลือกกลอง Value on 

Data Points ดังภาพดานลาง 

  

 
 
10. กดปุม Next ไปที่หนาตาง Sort เลือก Sort by Y-value Desceding  ดังภาพดานลาง 
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11. กดปุม Next ไปที่หนาตาง Stype เปล่ียน Orientation style จากแนวตั้งใหเปนแนวนอน  ดังภาพ

ดานลาง 

  
 

 
 
12. กดปุม Finish จะไดกราฟแทงที่แสดงจํานวนรหัส ICD ที่เปนรหัสโรคหลัก เรียงตามจํานวนผูปวยจาก

มากไปหานอย ดังภาพดานลาง 
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13. คลิกขวาทีกราฟแทงเพื่อปรับแตง Properties ไปที่ tab Dimension Limits คลิกเลือกกลอง 

Restrict which values are displayed during the first expression แลวยกเลิกการเลือก

กลอง Show Others ดังภาพดานลาง 

  

 
 
14. ไปที่ tab Dimension คลิกกลอง Suppress When Value is Null ดังภาพดานลาง 

  

 
 

Check Here 

Check Here 

Uncheck Here 
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15. กดปุม Finish เราจะไดกราฟแทงที่แสดงจํานวนรหัส ICD ที่เปนรหัสโรคหลัก 10 อันดับ ดังภาพ

ดานลาง 

 

 
 
อยางไรก็ตามการแสดงขอมูลในกราฟแทงน้ียังมีขอผิดพลาดอยู โดยหากทานมีความรูเรื่องรหัส ICD-10 ก็คง

จะทราบวารหสั Z380 เปนรหัสสําหรับเด็กที่คลอดปกติในโรงพยาบาล เชนเดียวกันรหัส O800 ก็เปนรหัสสําหรับหญิง

ที่มาคลอดบุตรในโรงพยาบาลโดยไมมีโรคแทรกซอน ซ่ึงในกราฟแทงน้ี แสดงเหมือนกับวา ผูปวยสองกลุมน้ีเปนโรค ซ่ึง

จริงๆแลว ไมควรแสดงขอมูลผูปวยสองกลุมดังกลาวในกราฟน้ี 

เราควรแกไขใหกราฟแทงน้ี แสดงสถิติโรคจริงๆ โดยควรตัดกราฟแสดงผูปวยเด็กแรกเกิดและหญิงคลอดปกติ

ออกไป โดยใชขั้นตอนดังตอไปน้ี 

 
1. สร้างกราฟแท่งใหม่จากกราฟเดิม โดย คลิกขวาที่กราฟแทงแลวเลือก menu Clone     
 
2. ตั้งชื่อกราฟใหมเปน สถิติรหัสโรคหลักของผูปวยใน 10 อันดับแรก ไมรวมเด็กแรกเกิดและหญิงคลอดปกติ   
  
3. คลิกขวาที่กราฟแทงแลวปรับแตง Properties ไปที่ tab Dimesnsion ดังภาพตอไป 
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4. คลิกปุม Edit เพื่อเปดหนาตาง Edit Expression เปล่ียนขอความภายในใหม ดังภาพดานลาง   
  

=IF(ICDIPDTYPE=1 AND ICDIPD <>'Z830' AND ICDIPD <> 'O800' ,ICDIPD)  
 

 
 
 
5. กดปุม OK เพื่อปดหนาตาง Edit Expression แลว กดปุม OK อีกครั้งเพื่อปดหนาตาง Chart 

Properties   
  

 
 

Prepare to Click 
“Edit” 
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ในขณะน้ี เราจะมีกราฟแทงอันที่สองเพื่อใชแสดง สถิติรหัส ICD โรคหลักที่พบบอย 10 อันดับแรกที่ไมรวม

เด็กแรกเกิดและหญิงคลอดปกติ ซ่ึงสามารถใชแสดงขอมูลใหถูกตองตามความเปนจริงได

เราสามารถปรับแตง Properties ของกราฟเพื่อแสดง สถิติที่พบบอย 5, 20 อันดับแรก หรือ กําหนดตัวเลข

อ่ืนๆไดอยางงายดาย

การสรางตารางแสดงโรครวม โรคแทรก โรคอื่นๆ สาเหตุการบาดเจ็บในกรณีของผูปวยใน 

เราจะสรางตารางแสดงโรครวม โดยดึงขอมูลเฉพาะโรครวมจากแฟม DIAGNOSIS_IPD เขาสูคลังขอมูล

เพิ่มเติม โดยจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม ที่อยูบน 

toolbar.

2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “COMOR”, ใน

tab COMOR พิมพขอความ “COMOR:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง

3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_IPD ที่เก็บไวใน Folder ใดๆ เชน

ในที่นี้อยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด
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ของไฟล ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย (ในกรณีเปด text file) ดังภาพ

ตอไป 

 

 
 
4. แกไข Script ในหนา COMOR ใหเปนดังตอไปน้ี 

COMOR: 
LOAD HOSPCODE&PID&AN AS ANID,  
     DIAGCODE AS COMOR 
      
FROM 
[C:\DataCenter\diagnosis_ipd.txt] 
(txt, codepage is 874, embedded labels, delimiter is '\t', msq) 
 
WHERE DIAGTYPE=2; 
  

 
5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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6. ทําซํ้าขั้นตอน 1-5 อีก 3 ครั้ง เพื่อสรางตาราง COMP (นําเขา Complication, DIAGTYPE=3) 

สรางตาราง OTHER (นําเขา Other Diagnosis, DIAGTYPE=4) และตาราง EXT (นําเขา 

External Causes, DIAGTYPE=5)  
 

7. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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การสรางตารางแสดงโรคอื่นๆ ในกรณีของผูปวยนอก 
 

เราจะสรางตารางแสดงโรคอ่ืนๆของผูปวยนอก โดยดึงขอมูลเฉพาะโรคอ่ืนๆจากแฟม DIAGNOSIS_OPD 

เขาสูคลังขอมูลเพิ่มเติม โดยจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “OPDOTH”, ใน 

tab OPDOTH พิมพขอความ “OPDOTH:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter 

เพื่อขี้นบรรทัดใหมดังภาพหนาจอดานลาง 

 

 
 
3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_OPD ที่เก็บไวใน Folder ใดๆ 

เชนในที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด

ของไฟล ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย (ในกรณีเปด text file) ดังภาพ

ตอไป 
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4. กดปุม Finish แลวแกไข Script ในหนา ICDOPD ใหเปนดังตอไปน้ี 

OPDOTH: 
LOAD HOSPCODE&PID&SEQ AS OPDID,  
     DIAGCODE AS ODXOTH  
      
FROM 
[C:\DataCenter\diagnosis_opd.txt] 
(txt, codepage is 874, embedded labels, delimiter is '|', msq) 
 
WHERE DIAGTYPE > 1;  
  

 
5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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การสรางตารางรายละเอียดของสถานพยาบาล 
 

เราจะสรางตารางแสดงโรครวม โดยดึงขอมูลเฉพาะโรครวมจาก เขาสูคลังขอมูลเพิ่มเติม โดยจะใชหนาจอ 

Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “HOSPITAL”, ใน 

tab HOSPITAL พิมพขอความ “HOSOPD” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter 

เพื่อขี้นบรรทัดใหมดังภาพหนาจอดานลาง 
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3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ healthcare.xlsx ที่เก็บไวใน Folder ใดๆ เชนใน

ที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียดของไฟล

ดังภาพตอไป

4. กดปุม Finish แลวแกไข Script ในหนา HOSPITAL ใหเปนดังตอไปน้ี
HOSOPD:
LOAD รหสัหน่วยงาน5หลกั AS OPDHOS,

ชืÉอหน่วยงานบริการสุขภาพ AS OPDHOSNAME,
ประเภท AS OPDHOSTYPE,
รหสัอาํเภอ AS OPDHOSAMPUR

FROM
[C:\DataCenter\healthcare.xlsx]
(ooxml, embedded labels, table is HealthCare);

HOSADM:
LOAD รหัสหน่ วยงาน5หลัก AS HOSADM,

ชืÉอหน่วยงานบริการสุขภาพ AS ADHOSNAME,
ประเภท AS ADHOSTYPE,
รหสัอาํเภอ AS ADHOSAMPUR

FROM
[C:\DataCenter\healthcare.xlsx]
(ooxml, embedded labels, table is HealthCare);

5. แกไข Script เพิ่มเติมในหนา Main ใหเปนดังตอไปน้ี

LOAD HOSPCODE AS HOSADM,
HOSPCODE&PID AS ID,
SEQ,
HOSPCODE&PID&AN AS ANID,
AN,
DATETIME_ADMIT,
……
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6. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชืÉอมโยงตารางดงัภาพต่อไปนี Ê 
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บทท่ี 8   

การวิเคราะหความผิดพลาดของการใหรหัส (ICD Coding Error Analysis) 
 

การวิเคราะหความผิดพลาดของการใหรหัส เปนการตรวจสอบความผิดพลาด 13 หัวขอ ตามหลักเกณฑการ

ตรวจสอบความผิดพลาดการใหรหัส ICD ในสถานพยาบาลของสํานักนโยบายและยุทธศาสตร กระทรวงสาธารณสุข ป 

พ.ศ. 2558 

 
ในบทน้ี เราจะฝกการใช Qlikview ชวยวิเคราะหความผิดพลาดของการใหรหัส ICD ในคลังขอมูล โดยใช

ขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Sheet3 ใหกลายเปน ErrorA1A2OPD 

  
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   

  
4. พิมพชื่อ “ความผิดพลาด A1A2 ใน OPD” เขาไปในชอง Window Title ในหนาจอ General แลว

เลือกภาพตาราง (Straight Table) ที่อยูในกรอบ Chart type ดังภาพตอไป  
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5. กดปุม Next เลือก DIAG จากชอง Available Fields/Groups แลวกดปุม Add เพื่อให ICDIPD 

เขาไปอยูในชอง Used Dimensions ดังภาพดานลาง 

 
 

6. กดปุม Next แลวพิมพขอความดานลางเชาไปอยูในชอง Edit Expression 

 
Count ( {$<ICDOPD={"B260"}+{"C60*"}+{"C61*"}+{"C62*"}+{"C63*"}+{"D074"}+{"D075"} 
+{"D076"}+{"D176"}+{"D29*"}+{"D40*"}+{"E29*"}+{"E895"}+{"F524"}+{"I861"} 
+{"L291"}+{"N40"}+{"N41"}+{"N42*"}+{"N43*"}+{"N44*"}+{"N45*"}+{"N46*"}+{"N47*"}+
{"N48*"}+{"N49*"}+{"N50*"}+{"N51*"}+{"Q53*"}+{"Q54*"}+{"Q55*"}+{"R86*"}+{"S312"}
+{"S313"}+{"Z125"},SEX={"2"}> } DISTINCT OPDID)  
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7. กดปุม OK แลวพิมพขอความ A1 เขาไปในชอง Label ดังภาพตอไป 

 

 
 

8. กดปุม Add แลวพิมพขอความดานลางเชาไปอยูในชอง Edit Expression 

 
Count ( {$<ICDOPD={"A34*"}+{"B373"}+{"C51*"}+{"C52*"}+{"C53*"}+{"C54*"}+{"C55*"} 
+{"C56*"}+{"C57*"}+{"C58*"}+{"C796"}+{"D06*"}+{"D070"}+{"D071"}+{"D072"} 
+{"D073"}+{"D25*"}+{"D26*"}+{"D27*"}+{"D28*"}+{"D39*"}+{"E28*"}+{"E894"}+ 
{"F525*"}+{"F53*"}+{"I863"}+{"L292"}+{"L705"}+{"M800*"}+{"M801*"}+{"M810*"} 
+{"M811*"}+{"M830*"}+{"N70*"}+{"N71*"}+{"N72*"} +{"N73*"}+{"N74*"}+{"N75*"} 
+{"N76*"}+{"N77*"} +{"N78*"}+{"N79*"}+{"N80*"}+{"N81*"}+{"N82*"}+{"N83*"} 
+{"N84*"}+{"N85*"}+{"N86*"}+{"N87*"}+{"N88*"}+{"N89*"}+{"N90*"}+{"N91*"}+ 
{"N92*"}+{"N93*"}+{"N94*"}+{"N95*"}+{"N96*"}+{"N97*"}+{"N98*"}+{"N992"}+{"N993"} 
+{"O*"}+{"P546"}+{"Q50*"}+{"Q51*"}+{"Q52*"}+{"R87"}+{"S314*"}+{"S374*"}+ 
{"S375*"}+{"S376*"}+{"T192"}+{"T193"}+{"T833"}+{"Y76*"}+{"Z014"}+{"Z124"}+ 
{"Z301"}+{"Z303"}+{"Z305"}+{"Z311"}+{"Z312"}+{"Z32*"}+{"Z33*"}+{"Z34*"}+{"Z35*"}
+{"Z36*"}+{"Z39*"}+{"Z437"}+{"Z875"}+{"Z975"}, SEX={"1"}> } DISTINCT OPDID)  
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9. กดปุม OK แลวพิมพขอความ A2 เขาไปในชอง Label ดังภาพตอไป 

 

 
 

10. ทําซํ้าขั้นตอนที่ 9-10 อีก 3 รอบ เพื่อเพิ่ม Expression อีก 3 รายการ โดยมีรายละเอียดคือ 

 Expression Label = จํานวนผูปวยทั้งหมด ; Definition = Count(DISTINCT OPDID) 

 Expression Label = RateA1 ตอแสน ; Definition = A1/จํานวนผูปวยทั้งหมด*100000 

 Expression Label = RateA2 ตอแสน ; Definition = A2/จํานวนผูปวยทั้งหมด*100000 

ใหไดผลลัพธดังภาพตอไป 
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11. กดปุม Finish จะไดตารางในภาพตอไป 

 

 
 
12. คลิกขวาแลวปรับแตง Properties ดาน Number ของตาราง เลือก Expression A1 ปรับ 

Number Format Setting เปน Integer แลวทําซํ้ากับ A2, จํานวนผูปวยทั้งหมด ตอจากน้ันเลือก 

Expression RateA1 ตอแสน ปรับ Number Format Settings เปน Fixed to 2 Decimal 

แลวทําซํ้ากับ Expression RateA2 ตอแสน ดังภาพตอไป 
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13. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Table Box หรือกด

ปุมรูป           ที่อยูบน toolbar ในชอง Title ใสขอความ “รายละเอียด Case” แลวเพิ่ม Fields เขา

สูตารางดังภาพตอไป 

 

 
 

14. จัดรูปแบบและวางตารางไวดานขวาของตารางแรก ดังภาพตอไป ถาเราคลิกเลือกรายชื่อโรงพยาบาลจาก

ตารางแรก รายละเอียดของผูปวยของโรงพยาบาลน้ันจะปรากฏในตารางที่สองน้ี 

 

 
 

15. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   
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16. พิมพชื่อ “Error A1A2 จําแนกตามสถานพยาบาล” เขาไปในชอง Window Title ในหนาจอ 

General แลวเลือกกราฟแทง (Bar chart) ที่อยูในกรอบ Chart type ดังภาพตอไป  

 

 
 

17. กดปุม Next ไปหนา Dimension เลือก OPDHOSNAME ดังภาพตอไป  
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18. กดปุม Next ไปหนา Edit Expression พิมพขอความดานลางเขาไป ดังภาพตอไป  

 
Count ({$ <ICDOPD={"B260"}+{"C60*"}+{"C61*"}+{"C62*"}+{"C63*"}+{"D074"}+{"D075"} 
+{"D076"}+{"D176"}+{"D29*"}+{"D40*"}+{"E29*"}+{"E895"}+{"F524"}+{"I861"}+ 
{"L291"}+{"N40"}+{"N41"}+{"N42*"}+{"N43*"}+{"N44*"}+{"N45*"}+{"N46*"}+{"N47*"} 
+{"N48*"}+{"N49*"}+{"N50*"}+{"N51*"}+{"Q53*"}+{"Q54*"}+{"Q55*"}+{"R86*"} 
+{"S312"}+{"S313"} +{"Z125"},SEX={"2"}> } DISTINCT OPDID)  

 

 
 

19. กดปุม OK ไปที่หนา Expression พิมพขอความ OPDA1Error เขาในชอง Label แลวคลิกเลือก 

Value on Data Points ดังภาพตอไป  
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20. กดปุม Next ไปที่หนา Sort แลวคลิกเลือก Sort by Y-value ดังภาพตอไป  

 

 
 

21. กดปุม Next ไปที่หนา Style แลวคลิกเลือก Orientation เปนกราฟแนวนอน ดังภาพตอไป 
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22. กดปุม Next ไปที่หนา Presentation แลวคลิกเลือก Enable X-Axis Scrollbar กําหนดตัวเลข

ในชอง When Number of Items Exceeds เปนเลข 10 ดังภาพตอไป 

 

 
 

23. กดปุม Next สองครั้งไปที่หนา Colors เลือก Multicolored ดังภาพตอไป 

 

 
 

24. กดปุม Finish จะไดกราฟแสดงสถานพยาบาลที่เกิดความผิดพลาดที่ OPD แบบ A1 ดังภาพตอไป 
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25. จัดวางตําแหนงของกราฟอยูดานชวาสุด ดังภาพตอไป  

 

 
 

26. Clone กราฟแทงโดยคลิกขวาแลวเลือกเมนู ดังภาพตอไป  
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26. ตั้งชื่อกราฟที่ Clone มาใหชื่อใหมเปน  ErrorA2 จําแนกตามสถานพยาบาล แลวปรับแตงคุณสมบัติ 

Expression แกไขขอความใน Expression ตามขอความดานลางดังภาพตอไป 

 
Count ( {$ 
<ICDOPD={"A34*"}+{"B373"}+{"C51*"}+{"C52*"}+{"C53*"}+{"C54*"}+{"C55*"}+{"C56*"} 
+{"C57*"}+{"C58*"}+{"C796"}+{"D06*"}+{"D070"}+{"D071"}+{"D072"}+{"D073"}+{"D25*"
}+{"D26*"}+{"D27*"}+{"D28*"}+{"D39*"}+{"E28*"}+{"E894"}+{"F525*"}+{"F53*"} 
+{"I863"} +{"L292"}+{"L705"} +{"M800*"}+{"M801*"}+{"M810*"}+{"M811*"} +{"M830*"} 
+{"N70*"}+{"N71*"} +{"N72*"}+{"N73*"}+{"N74*"}+{"N75*"}+{"N76*"} +{"N77*"} 
+{"N78*"} +{"N79*"} +{"N80*"}+{"N81*"}+{"N82*"}+{"N83*"}+{"N84*"} 
+{"N85*"}+{"N86*"} +{"N87*"}+{"N88*"} +{"N89*"}+{"N90*"}+{"N91*"}+{"N92*"} 
+{"N93*"}+{"N94*"}+{"N95*"}+{"N96*"}+{"N97*"}+{"N98*"}+{"N992"}+{"N993"} 
+{"O*"}+{"P546"}+{"Q50*"}+{"Q51*"}+{"Q52*"}+{"R87"}+{"S314*"}+{"S374*"} 
+{"S375*"}+{"S376*"}+{"T192"}+{"T193"}+{"T833"}+{"Y76*"}+{"Z014"}+{"Z124"} 
+{"Z301"}+{"Z303"}+{"Z305"}+{"Z311"}+{"Z312"}+{"Z32*"}+{"Z33*"} 
+{"Z34*"}+{"Z35*"}+{"Z36*"}+{"Z39*"}+{"Z437"}+{"Z875"}+{"Z975"}, SEX={"1"}> } 
DISTINCT OPDID)   

 

 
 

27.  กดปุม OK แลวจัดตําแหนงใหเหมาะสม ดังภาพตอไป 
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28. สราง object ใหม โดยเลือก menu Object => New Sheet Object => List Box หรือกดปุม

รูป           ที่อยูบน toolbar ในชอง Title ใสขอความ “ICD เฉพาะเพศชาย” ดังภาพตอไป 

 

 
 

29.  ไปที ่Tab Expressions กดปุม Add แลวพิมพขอความดานลางเขาไปในชอง Edit Expression 

ดังภาพตอไป 
 
=IF(ICDOPD= 'B260' OR (ICDOPD >= 'C600' AND ICDOPD <= 'C639') OR ICDOPD= 'D074' 
OR ICDOPD= 'D075' OR ICDOPD= 'D076' OR ICDOPD= 'D176' OR (ICDOPD >= 'D290' AND 
ICDOPD <= 'D299') OR (ICDOPD>= 'D400' AND ICDOPD <= 'D409') OR (ICDOPD>= 'E290' 
AND ICDOPD <= 'E299') OR ICDOPD= 'E895' OR ICDOPD= 'F524' OR ICDOPD= 'I861' OR 
ICDOPD = 'L291' OR ICDOPD= 'N40' OR ICDOPD= 'N41' OR (ICDOPD>= 'N420' AND ICDOPD 
<='N519')  OR (ICDOPD >= 'Q530' AND ICDOPD<='Q559') OR (ICDOPD >= 'R860' AND 
ICDOPD <='R869') OR ICDOPD= 'S312' OR ICDOPD= 'S313' OR ICDOPD= 'Z125' , ICDOPD) 
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30.  กดปุม OK จะได List Box แสดงรายการรหัส ICD เฉพาะเพศชาย ดังภาพตอไป 

 
 

31.  ทําซํ้าขั้นตอนที่ 28-30 เพื่อสราง List Box แสดงรายการรหัส ICD เฉพาะเพศหญิง โดยกําหนด 

Expression ดวยขอความดานลาง ดังภาพตอไป 

 
=IF ((ICDOPD>='A340' AND ICDOPD<='A349') OR ICDOPD='B373' OR (ICDOPD>='C510' AND 
ICDOPD<='C589') OR ICDOPD='C796' OR (ICDOPD>='D060' AND ICDOPD <='D069') OR 
ICDOPD='D070' OR ICDOPD='D073' OR (ICDOPD>='D250' AND ICDOPD<='D289') 
OR (ICDOPD>='D390' AND ICDOPD <='D399') OR (ICDOPD>='E280' AND ICDOPD <='E289') 
OR ICDOPD='E894' OR (ICDOPD>='F525' AND ICDOPD <='F5259') OR (ICDOPD >='F53' AND 
ICDOPD <='F539') OR ICDOPD='I863' OR ICDOPD='L292' OR ICDOPD='L705' OR  
(ICDOPD>='M800' AND ICDOPD<='M8019') OR (ICDOPD>='M810' AND ICDOPD<='M8119') OR 
ICDOPD='M830' OR (ICDOPD>='N70' AND ICDOPD<='N989') OR ICDOPD='N992' OR 
ICDOPD='N993'OR (ICDOPD>='O00' AND ICDOPD <='O999') OR ICDOPD='P546' OR 
(ICDOPD>='Q50' AND ICDOPD='Q529') OR ICDOPD='R87' OR (ICDOPD>='S314' AND ICDOPD 
<'S3149') OR (ICDOPD>='S374' AND ICDOPD='S3769') OR ICDOPD='T192' OR 
ICDOPD='T193' OR ICDOPD='T833' OR (ICDOPD>='Y76' AND ICDOPD <='Y7699') OR 
ICDOPD='Z014' OR ICDOPD='Z124' OR ICDOPD='Z301' OR ICDOPD='Z303' 
OR ICDOPD='Z305' OR ICDOPD='Z311' OR ICDOPD='Z312' OR (ICDOPD>='Z32' AND 
ICDOPD<='Z369') OR (ICDOPD>='Z39' AND ICDOPD <='Z399') OR ICDOPD='Z437' OR 
ICDOPD='Z875' OR ICDOPD='Z975'  , ICDOPD)  

 

 
 

32. สราง object ใหม โดยเลือก menu Object => New Sheet Object => List Box หรือกดปุม

รูป           ที่อยูบน toolbar ในชอง Field เลือก SEX ดังภาพตอไป 
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33. กดปุม OK จะได List Box ที่แสดงเพศ ใชเลือกเพศที่ตองการ 

34. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Current 

Selection Box หรือกดปุมรูป           ที่อยูบน toolbar เพื่อเปดกรอบโตตอบ ดังภาพตอไป 

 

 
 

35. กดปุม OK จะได Current Selection Box ใชแสดงรายการที่เลือกดูอยูในปจจุบัน จัดวางตําแหนงไว

ดานลางซายของแผนงาน ดังภาพตอไป 
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36. เราสามารถใชแผนงานน้ี คนหารายละเอียด Case ที่ผิดพลาดได โดยถาตองการดูการใหรหัส ICD เพศ

หญิงในผูปวยชาย ใหเลือก List Box ICD เฉพาะหญิง โดยคลิกขวาที่ List Box แลวเลือกรายการ

ทั้งหมด (Select All) ตอจากน้ันเลือกเพศชายใน List Box SEX รายละเอียดของ Case จะปรากฏใน

ตารางตอนกลาง ซ่ึงเราสามารถสงออกเปน Excel file โดยกดที่ปุม XL ดานบนขวาของตาราง ดังภาพ

ตอไป 
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Error A1 และ A2 ที่พบในผูปวย IPD 

 
ตอไปน้ี เปนการวิเคราะหความผิดพลาดของการใหรหัส ICD แบบ A1 และ A2 ที่พบในผูปวยใน โดยใช

ขั้นตอนดําเนินการดังตอไปน้ี 

 
1. คัดลอก worksheet ErrorA1A2OPD เพื่อสราง worksheet ใหม ดวยการคลิกขวาที่สวนหัวของ 

worksheet แลวเลือก เมนู Copy Sheet ดังภาพตอไป 

 

 
 
2. ตั้งชื่อ worksheet ใหมดวยการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Copy of ErrorA1A2OPD ให

กลายเปน ErrorA1A2IPD 

 
3. แผนงานน้ีใชแสดงความผิดพลาดแบบ A1 และ A2 ที่พบในผูปวย IPD เราจึงตองแกไขการแสดงผล

ทั้งหมดในทุกๆตารางและกราฟ ใหแสดงผลจากขอมูล IPD เริ่มจากการปรับแตงตารางแรกดานซายบน

ดวยการคลิกขวาเลือกเมนู Properties ดังภาพตอไป 
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4. เปล่ียนชื่อตารางใหเปน “ความผิดพลาด A1,A2 ใน IPD” แลวไปที่ Tab Dimensions เปล่ียน

รายการในชอง Used Dimensions จากเดิม OPDHOSNAME ใหกลายเปน ADHOSNAME 

ดังภาพตอไป 

 

 
 
5. ไปที่ Tab Expression เปล่ียน Definition ของคอลัมน A1 ใหแสดงผลจากรหัส IPD โดยนับตาม 

ANID ดังภาพตอไป 

 

 
 

6. ไปที่ Tab Expression เปล่ียน Definition ของคอลัมน A2 ใหแสดงผลจากรหัส IPD โดยนับตาม 

ANID ดังภาพตอไป 

 

 
 

7. กดปุม OK ปดหนาตาง Edit Expression และ กดปุม OK อีกครั้ง เสร็จการปรับแตงตารางแรก 
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8. ปรับแตงคุณสมบัติของตารางตอไป คือตารางรายละเอียด Case คลิกขวาที่ตารางแลวเลือกเมนู 

Properties ดังภาพตอไป 

 

 
 

9. ไปที่ Tab General ในชอง Fields Displayed inTablebox เปล่ียนแปลงรายการ ดังภาพตอไป 

 

 
 

10. กดปุม OK แลวปรับขนาดของคอลัมนใหเหมาะสม ดังภาพตอไป 
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11. ปรับแตงคุณสมบัติของ กราฟ Error A1-OPD จําแนกตามสถานพยาบาล คลิกขวาที่กราฟแลวเลือก

เมนู Properties ดังภาพตอไป 

 

 
 

12. เปล่ียนชื่อกราฟเปน “Error A1-IPD จําแนกตามสถานพยาบาล” แลวปรับแตง Dimensions ใหใช 

ADHOSNAME แลวปรับแตง Expression ดังน้ี 

 
Count ({$ <ICDIPD={"B260"}+{"C60*"}+{"C61*"}+{"C62*"}+{"C63*"}+{"D074"}+{"D075"} 
+{"D076"}+{"D176"}+{"D29*"}+{"D40*"}+{"E29*"}+{"E895"}+{"F524"}+{"I861"}+ 
{"L291"}+{"N40"}+{"N41"}+{"N42*"}+{"N43*"}+{"N44*"}+{"N45*"}+{"N46*"}+{"N47*"} 
+{"N48*"}+{"N49*"}+{"N50*"}+{"N51*"}+{"Q53*"}+{"Q54*"}+{"Q55*"}+{"R86*"} 
+{"S312"}+{"S313"} +{"Z125"},SEX={"2"}> } DISTINCT ANID) 
  

 
13. กดปุม OK เพื่อเสร็จส้ินการปรับแตงกราฟ 

14. ทําการปรับแตงโดยใชหลักการเดียวกัน ในวัตถุตางๆที่เหลือดังน้ี 

 
Object การปรับแตง 

กราฟ Error A2 เปล่ียนชื่อ, เปล่ียน Dimension, แกไข Expression 

Listbox ICD เฉพาะชาย แกไข Expression (เปล่ียน ICDOPD เปน ICDIPD) 

Listbox ICD เฉพาะหญิง แกไข Expression (เปล่ียน ICDOPD เปน ICDIPD) 

 

15. เราสามารถใชแผนงานน้ี คนหารายละเอียด Case ที่ผิดพลาดได โดยถาตองการดูการใหรหัส ICD เพศ

หญิงในผูปวยชาย ใหเลือก List Box ICD เฉพาะหญิง โดยคลิกขวาที่ List Box แลวเลือกรายการ

ทั้งหมด (Select All) ตอจากน้ันเลือกเพศชายใน List Box SEX รายละเอียดของ Case จะปรากฏ

ในตารางตอนกลาง ลักษณะเชนเดียวกับการใชงานแผนงาน ErrorA1A2OPD 
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Error B1 ที่พบในผูปวย OPD 

 
ตอไปน้ี เปนการวิเคราะหความผิดพลาดของการใหรหัส ICD แบบ B1 ที่พบในผูปวย OPD โดยใชขั้นตอน

ดําเนินการดังตอไปน้ี 

 
1. คัดลอก worksheet ErrorA1A2OPD เพื่อสราง worksheet ใหม ดวยการคลิกขวาที่สวนหัวของ 

worksheet แลวเลือก เมนู Copy Sheet ดังภาพตอไป 

 

 
 
2. ตั้งชื่อ worksheet ใหมดวยการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Copy of ErrorA1A2OPD ให

กลายเปน ErrorB1OPD 

 
3. แผนงานน้ีใชแสดงความผิดพลาดแบบ B1 ที่พบในผูปวย OPD เราจึงตองปรับแตงตารางแรกดานซายบน

ดวยการคลิกขวาเลือกเมนู Properties ดังภาพตอไป 
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4. เปล่ียนชื่อตารางใหเปน “ความผิดพลาด B1 ใน รพ.สต.” แลวไปที่ Tab Dimensions เปล่ียนรายการ

ในชอง Used Dimensions โดยกดปุม Edit ดังภาพตอไป 

 

 
 

5. ในหนาจอ Edit Expression แกไขขอความ เพื่อใหแสดงรายการเฉพาะสถานพยาบาลที่เปน รพ.สต. 

(รหัสประเภทสถานพยาบาล = 18) ดังภาพตอไป 

 

 
 

6. กดปุม OK แลวพิมพขอความ “รายชื่อรพ.สต.” ในชอง Label ดังภาพตอไป 
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7. ไปที่ Tab Expression ปรับแตง Expressions ใหเหลือ 3 รายการ ดังภาพตอไป 

 

 
 

 8. แกไขคุณสมบัติ Expressions ทั้ง 3 รายการ ใหมีรายละเอียดดังน้ี 

 
Expression Definition 
จํานวนรหัส Z 

ที่ไมใชคัดกรอง 

Count ( {$ 
<ODXOTH={"Z0*"}+{"Z10*"}+{"Z14*"}+{"Z15*"}+{"Z16*"}+{"Z17*
"}+{"Z18*"}+{"Z19*"}+{"Z2*"}+{"Z3*"}+{"Z4*"}+{"Z5*"}+{"Z6*
"}+{"Z7*"}+{"Z8*"}+{"Z9*"}, ICDOPDTYPE={"1"}, 
ICDOPD={"A*"}+{"B*"}+{"C*"}+{"D*"}+{"E*"}+{"F*"} 
+{"G*"}+{"H*"}+{"I*"}+{"J*"}+{"K*"}+{"L*"}+{"M*"}+{"N*"}+ 
{"O*"}+{"P*"}+{"Q*"}+{"R*"}+{"S*"}+{"T*"}+{"U*"}> } 
DISTINCT OPDID)  

จํานวนผูปวย

ทั้งหมด 

Count ( {$ <ICDOPDTYPE={"1"}, ICDOPD={"A*"}+{"B*"} 
+{"C*"}+{"D*"}+{"E*"}+{"F*"}+{"G*"}+{"H*"}+{"I*"}+{"J*"}+ 
{"K*"}+{"L*"}+{"M*"}+{"N*"}+{"O*"}+{"P*"}+{"Q*"} 
+{"R*"}+{"S*"}+{"T*"}+{"U*"}> } DISTINCT OPDID)  
 

รอยละ [จาํนวนรหสั Z ทีÉไม่ใช่คดักรอง]/จาํนวนผูป่้วยทัÊงหมด 

 

 9. ไปที่ Tab Number ปรับแตงการแสดงผล จํานวนรหัสและจํานวนผูปวยเปนแบบ Interger และ

รอยละเปนทศนิยม 2 ตําแหนงดังภาพตอไป 
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 10.  กดปุม OK ปรับแตงคุณสมบัติของ กราฟ Error A1-OPD จําแนกตามสถานพยาบาล คลิกขวาที่

กราฟแลวเลือกเมนู Properties ดังภาพตอไป 

 

 
 

12. เปล่ียนชื่อกราฟเปน “Error B1-OPD จําแนกตามสถานพยาบาล” แลวปรับแตง Dimensions 

ดังน้ี 
 
=IF(Left(OPDHOSTYPE,2)='18', OPDHOSNAME)  

 

12. ปรับแตง Expression ดังน้ี 

 
Count ( {$ <ODXOTH={"Z0*"}+{"Z10*"}+{"Z14*"}+{"Z15*"}+{"Z16*"}+{"Z17*"} 
+{"Z18*"}+{"Z19*"}+{"Z2*"}+{"Z3*"}+{"Z4*"}+{"Z5*"}+{"Z6*"}+{"Z7*"}+{"Z8*"} 
+{"Z9*"}, ICDOPDTYPE={"1"}, ICDOPD={"A*"}+{"B*"}+{"C*"}+{"D*"}+{"E*"}+{"F*"} 
+{"G*"}+{"H*"}+{"I*"}+{"J*"}+{"K*"}+{"L*"}+{"M*"}+{"N*"}+{"O*"}+{"P*"}+{"Q*"} 
+{"R*"}+{"S*"}+{"T*"}+{"U*"}> } DISTINCT OPDID)  

  
13. กดปุม OK เพื่อเสร็จส้ินการปรับแตงกราฟ 

14. ลบ กราฟที่เหลือ (Error A2) ทิ้งไป โดยการคลิกขวาแลวเลือกเมนู Remove 

 
 
15. ทําการปรับแตงโดยใชหลักการเดียวกัน ในวัตถุตางๆที่เหลือดังน้ี 

 
Object การปรับแตง 

Listbox ICD เฉพาะชาย เปล่ียนชื่อเปน “รหัส ICD” แลวแกไข Expression เปน 
=IF(ICDOPD>'A' AND ICDOPD <'V00', 
ICDOPD) 
และปรับแตงการเรียง Sort by Text A-Z 

Listbox ICD เฉพาะหญิง เปล่ียนชื่อเปน “รหัส Z อ่ืน” แกไข Expression เปน 
=IF((ODXOTH>'Z00' AND ODXOTH 
<'Z11') OR ODXOTH > 'Z139', 
ODXOTH) และปรับแตงการเรียง Sort by Text A-Z  

 



98 
 

 
Object การปรับแตง 

Listbox SEX เปล่ียน Field ที่แสดงผลจาก SEX เปล่ียนเปน 

ICDOPDTYPE 
ตารางรายละเอียด Case เปล่ียน Field ที่แสดงผลจาก SEX เปล่ียนเปน 

ODXOTH 
 

 
16. เราสามารถใชแผนงานน้ี คนหารายละเอียด Case ที่ผิดพลาดได โดยคลิกขวาที่ List Box รหัส ICD 

แลวเลือกรายการทั้งหมด (Select All) ตอจากน้ันคลิกขวา List Box รหัส Z อ่ืนๆ แลวเลือกรายการ

ทั้งหมด (Select All) รายละเอียดของ Case ที่ผิดพลาด จะปรากฏในตารางตอนกลาง ลักษณะ

เชนเดียวกับการใชงานแผนงานอ่ืนๆ   

 
 
 
ฝกปฎิบัติบทท่ี 8 : สรางแผนงานเพ่ิมเติมเพ่ือแสดง 

 
8.1 Error B2 ถึง B10 โดยมีรายละเอียด คําสั่งคนหาดังน้ี 

 
B2OPD Count ( {$ <ICDOPD={"V*"}+{"W*"}+{"X*"}+{"Y*"}, 

ICDOPDTYPE ={"1"}> } DISTINCT OPDID) 
B2IPD Count ( {$ <ICDIPD={"V*"}+{"W*"}+{"X*"}+{"Y*"}, 

ICDIPDTYPE ={"1"}> } DISTINCT ANID) 

B3OPD Count ( {$ <ICDOPD={"S*"}+{"T*"}> } DISTINCT OPDID)  
- Count( {$ <ICDOPD={"S*"}+{"T*"}, ODXOTH = 
{"V*"}+{"W*"}+{"X*"}+{"Y*"}>} DISTINCT OPDID) 

B3IPD Count ( {$ <ICDIPD={"S*"}+{"T*"}> } DISTINCT ANID)  
- Count( {$ <ICDIPD={"S*"}+{"T*"}, ICDEXT = 
{"V*"}+{"W*"}+{"X*"}+{"Y*"}>} DISTINCT ANID) 

B4OPD Count ( {$ 
<ICDOPD={"Z23*"}+{"Z24*"}+{"Z25*"}+{"Z26*"}+{"Z27*"}, 
ODXOTH={"Z00*"}+{"Z01*"}+{"Z02*"} > } DISTINCT OPDID) 

B5OPD Count ( {$ 
<PROCEDCODE={"9018170"}+{"9038170"}+{"9088170"}> } 
DISTINCT OPDID)   

B6OPD Count ( {$ <ICDOPD={"*"}, ODXOTH={"Z768"}> } DISTINCT 
OPDID)   

B7IPD Count ( {$ <ICDOPD={"*"}, ODXOTH={"Z768"}> } DISTINCT 
OPDID)   

B8OPD Count ( {$ <ICDOPD={"T31*"},ICDOPDTYPE={"1"}> } 
DISTINCT OPDID)   

B8IPD Count ( {$ <ICDIPD={"T31*"},ICDIPDTYPE={"1"}> } 
DISTINCT ANID)   

B9OPD Count ( {$ <ICDOPD={"V*"}+{"W*"}+{"X"}+{"Y"}-
{"V????"}-{"W????"}-{"X????"}-{"Y1???"}-{"Y2???"}-
{"Y30??"}-{"Y31??"} 
-{"Y32??"}-{"Y33??"}-{"Y34??"}> } DISTINCT OPDID) 
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B9IPD Count ( {$ <ICDIPD={"V*"}+{"W*"}+{"X"}+{"Y"}-{"V????"}-

{"W????"}-{"X????"}-{"Y1???"}-{"Y2???"}-{"Y30??"}-{"Y31??"} 
-{"Y32??"}-{"Y33??"}-{"Y34??"}> } DISTINCT ANID)   
B10 OPD 

Count ( {$ <ICDOPD={"S*"}+{"T*"},ICDOPDTYPE={"1"}, ODXOTH 
={"Z47*"}+{"Z48*"}> } DISTINCT OPDID) 
+ Count ( {$ <ICDOPD={"Z47*"}+{"Z48*"},ICDOPDTYPE={"1"}, 
ODXOTH ={"S*"}+{"T*"}> } DISTINCT OPDID) 

B10IPD Count ( {$ <ICDIPD={"S*"}+{"T*"},ICDIPDTYPE={"1"}, ICDCOMOR 
={"Z47*"}+{"Z48*"}> } DISTINCT ANID)  
+ Count ( {$ <ICDIPD={"Z47*"}+{"Z48*"},ICDIPDTYPE={"1"}, 
ICDCOMOR ={"S*"}+{"T*"}> } DISTINCT ANID) 

 

8.2 Error C1 และ C2 โดยมีรายละเอียด คําสั่งคนหาดังน้ี 

 
C1OPD Count ( {$ 

<ICDOPD={"J069"}+{"D229"}+{"L029"}+{"L039"}+{"T07*"}+{"T14*"}> 
} DISTINCT OPDID) 

C1IPD Count ( {$ 
<ICDIPD={"J069"}+{"D229"}+{"L029"}+{"L039"}+{"T07*"}+{"T14*"}> 
} DISTINCT ANID) 

 
 
การทํารายงานสรุปแยกตามอําเภอและสถานพยาบาล 

 
ตอไปน้ี เปนการสรางตารางสรุปความผิดพลาดของการใหรหัสผูปวย OPD จําแนกตามอําเภอและ

สถานพยาบาลในแตละอําเภอ โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title ใหกลายเปน Report by Amphur - OPD 

  
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   

  
4. พิมพชื่อ “รายงานความผิดพลาดการใหรหัส ICD ในผูปวย OPD จําแนกตามอําเภอ” เขาไปในชอง 

Window Title ในหนาจอ General แลวเลือกภาพตาราง (Pivot Table) ที่อยูในกรอบ Chart 

type ดังภาพตอไป  
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5. กดปุม OK กําหนด Dimension รวม 3 Dimensions คือ  OPDHOSAMPUR, OPDHOS 

และ OPDHOSNAME ดังภาพตอไป  

 

 
 
 

6. กดปุม Next ไปที่หนา Edit Expression พิมพขอความ ดังภาพตอไป  
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7. กดปุม OK แลวพิมพขอความ “จํานวนผูปวย” ในชอง Label  

 
8. กดปุม Add เพิ่ม Expression อีก 13 รายการ ดังรายละเอียด 

 
Label Expression 
ErrorA1 คําส่ังที่นับจํานวน Error A1 ใน OPD 

ErrorA2 คําส่ังที่นับจํานวน Error A2 ใน OPD 

ErrorB1 คําส่ังที่นับจํานวน Error B1 ใน OPD 

ErrorB2 คําส่ังที่นับจํานวน Error B2 ใน OPD 

ErrorB3 คําส่ังที่นับจํานวน Error B3 ใน OPD 

ErrorB4 คําส่ังที่นับจํานวน Error B4 ใน OPD 

ErrorB5 คําส่ังที่นับจํานวน Error B5 ใน OPD 

ErrorB6 คําส่ังที่นับจํานวน Error B6 ใน OPD 

ErrorB8 คําส่ังที่นับจํานวน Error B8 ใน OPD 

ErrorB9 คําส่ังที่นับจํานวน Error B9 ใน OPD 

ErrorB10 คําส่ังที่นับจํานวน Error B10 ใน OPD 

ErrorC1 คําส่ังที่นับจํานวน Error C1 ใน OPD 

TotalError (ErrorA1+ErrorA2+ErrorB1+ErrorB2+ErrorB3+ErrorB4 
+ErrorB5+ErrorB6+ErrorB8+ErrorB9+ErrorB10+ErrorC1)/
จาํนวนผูป่้วย  

  
9. กดปุม Finish จะไดตารางรายงานที่แยกตามอําเภอ ดังภาพดานลาง 
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10. ตารางน้ีสามารถขยายรายละเอียดเพื่อแสดงสถานพยาบาลในแตละอําเภอได โดยการคลิกขวาที่ปุม

เครื่องหมาย + ในคอลัมนแรก แลวเลือก Expand All ดังภาพดานลาง 

 
 

 
 

 
 
 
เราสามารถสงขอมูลจากตารางน้ี ไปสู Excel ไดโดยการกดปุม XL ดานบนขวาของตาราง 

 

ฝกปฎิบัติบทท่ี 8 : สรางตารางเพ่ิมเติมเพ่ือแสดง 

 
8.3 รายงานความผิดพลาดการใหรหัส ICD ในผูปวย IPD จําแนกตามอําเภอ 
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บทที่ 9  
การปรับแตงคลังขอมูลใหมีประสิทธิภาพ ใชงานงาย  

 
คลังขอมูลจะเปนแหลงขอมูลหลักที่เราสามารถใชในการใหบริการขอมูลภายในหรือภายนอกหนวยงาน จึงควร

ปรับแตงคลังขอมูลใหสวยงาม มีประสิทธิภาพ และใชงานงาย เพื่อใหผูใชเกิดความสะดวก และสามารถใชคลังขอมูล

คนหา แสดงขอมูลทีต่องการไดอยางรวดเร็ว ตรงตามความตองการ 

การปรับแตงคลังขอมูลใหมีประสิทธิภาพและใชงานงาย ทําไดโดยขั้นตอนตางๆดังตอไปน้ี 

 

การจัดโครงสรางและสวนแสดงผลของคลังขอมูล 
คลังขอมูลมักจะมีเน้ือหาจํานวนมาก จึงควรจัดโครงสรางเปนหลายสวน ไดแก สวนแนะนําคลังขอมูล สวน

แสดงผล และสวนอางอิง เราสามารถใช Qlikview สรางสวนตางๆของคลังขอมูลไดดังตอไปน้ี 

 

การเพ่ิมเติมและจัดตําแหนง Sheet 
การเพิ่ม Sheet ในคลังขอมูล ทําไดโดยการเรียกคําส่ังจากเมนู Layout => Add Sheet… ดังน้ี 

 
 
 
 
 
 
 
 
 
 
 
Sheet ใหมที่เพิ่มขึ้นมาน้ี เราสามารถปรับแตงได โดยการคลิกขวาที่ ตําแหนงหัวของSheet จะปรากฎเมนู

ขึ้นมา ใหเลือก Sheet Properties… ดังน้ี 
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เราสามารถปรับแตงคุณสมบัติของ Sheet ไดในกรอบโตตอบน้ี เชน ตั้งชื่อ Sheet ใหม ปรับเปล่ียน 

Background ปรับการแสดงลักษณะสีตางๆ  

เราสามารถปรับตําแหนง Sheet ใหเล่ือนไปทางซายหรือทางขวาได โดยใชคําส่ัง จาก เมนู Layout => 

Promote Sheet (เล่ือนไปทางซาย) หรือ Layout => Demote Sheet (เล่ือนไปทางขวา) ดังภาพตอไปน้ี 

 
 
 
 
 
 
 
 
 
 
 
 

ฝกฝนเพิ่มเติม 

ลองสราง Sheet แนะนําคลังขอมูล กําหนดตําแหนงเปน Sheet แรกสุด และ Sheet เก่ียวกับคลังขอมูล 

กําหนดไวเปน Sheet หลังสุด 
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การสราง Sheet แนะนําคลังขอมลู 

หนาแรกของคลังขอมูล ควรเปนหนาที่มีขอความแนะนําคลังขอมูล ความเปนมา วัตถุประสงค และขอความ

อ่ืนๆที่ตองการแนะนํา อาจมีรูปภาพ ตราสัญลักษณของหนวยงาน เพื่อใหมีลักษณะนาเชื่อถือ เราสามารถใสขอความใน 

Sheet แนะนําคลังขอมูลดังน้ี 

ใสกรอบขอความโดย เลือก เมนู Object => New Sheet Object => Text Object… หรือกด

ปุม      

ใน  Toolbar ดังน้ี 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
เราสามารถใสขอความ แนะนําไดใน Text Object ดังภาพตอไปน้ี 
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ฝกฝนเพิ่มเติม 

ลองเพิ่มขอความแนะนําคลังขอมูล ปรับแตง ขนาดและสีตัวอักษร พื้นหลัง และการจัดตําแหนงตางๆ ตาม

ตองการ 

 

การใสรูปใน Sheet คลังขอมูล 

การใสรูปทําโดย เลือก เมนู Object => New Sheet Object => Text Object… หรือกดปุม      

บน Toolbar ดังภาพตอไปน้ี 

 
 
ในหัวขอ Background เลือกรายการ Image แลวกดปุม Change เพื่อเลือก File รูปภาพที่ตองการ 

แลวกดปุม OK 
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จะไดรูปที่ตองการ สามารถปรับแตงคุณสมบัติตางๆได โดยคลิกขวาเลือก Properties 

 

การเพ่ิมปุมกดใน Sheet คลังขอมูล 

เราสามารถใสปุมกด ที่กําหนดใหเกิด action ตางๆ ในคลังขอมูลของเราได  

การใสปุมกดทําโดย เลือก เมนู Object => New Sheet Object => Text Object… หรือกด

ปุม        บน Toolbar ดังภาพตอไปน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เราจะลองสรางปุมที่กดแลว จะเปล่ียน Sheet ไปหนาถัดไป โดยพิมพขอความในชอง Text วา “ไปหนา

ถัดไป” ดังน้ี 
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กดปุม OK จะไดปุมขึ้นมา 1 ปุม ดังน้ี 

 
 
 

กําหนดใหปุมน้ีมี action โดย คลิกขวาเรียกเมนู Properties… แลวปรับแตงใน tab action โดยกด

ปุม Add ดังน้ี 

 

 
 
เลือก Action Type : เปน Layout เลือก Action เปน Activate Next Sheet แลวกดปุม OK 

สองครั้ง เราจะไดปุมมี action เม่ือกดแลวจะเปล่ียนหนา Sheet เปนหนาถัดไป 

 
ฝกฝนเพิ่มเติม 

ลองเพิ่มปุม “กลับไปหนากอน” หรือ ปุมอ่ืนๆตามตองการ 

 

การ Copy Sheet  
บางครั้งเราตองการให Sheet มีลักษณะคลายๆกัน หลาย Sheet ถาเราไมตองการสราง Object ซํ้าๆกัน

ในแตละ Sheet เราก็สามารถ Copy Sheet ไปไดเลย  

 
 
 
 
 
 
 



109 
 

การ Copy Sheet ทําโดย คลิกขวาที่ Sheet แลวเลือก Copy Sheet ดังน้ี 

 
 
 

 
 

 
 

 
 
 
 
 

การปรับเปลีย่นรูปแบบของกราฟ 
กราฟหลายแบบที่มีลักษณะการแสดงขอมูลคลายๆกัน สามารถปรับเปล่ียนรูปแบบกลับไปกลับมาได เชน 

ระหวางกราฟแทงกับกราฟวงกลม 

การปรับเปล่ียนรูปแบบของกราฟ ทําไดโดยคลิกขวา เลือก Properties… Tab General ดังภาพ 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ในที่น้ีตองการเปล่ียน กราฟแทงเปนกราฟวงกลม จึงเลือกภาพกราฟวงกลม แลวกดปุม OK 

 
 
 
 
 
 



110 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
กราฟแทงเปล่ียนเปนกราฟวงกลมตามตองการ หรือหากตองการกําหนดการแสดงผลภายในกราฟใหมีปุมปรับ

การแสดงผลไดหลายแบบ สามารถกําหนดจาก Tab General ในชอง Fast Type Change Allow Type 

ไดเลยดังภาพ 

 

 
 
 
 
 
 
 
 
ในภาพน้ี กําหนดใหสามารถเปล่ียนรูปแบบกราฟไดเปน 3 แบบ คือ กราฟแทง (Bar Chart) กราฟเสน 

(Line Chart) และ กราฟวงกลม (Pie Chart) เม่ือกดปุม OK จะพบวาตรงกรอบดานบนขวาของกราฟจะมีปุมที่

ใชปรับลักษณะ ถากดปุมน้ัน กราฟจะเปล่ียนลักษณะไปไดเรื่อยๆ 

 
 

 
 
 
 
 
 
 

ปุ่ มทีÉใช้ปรับลกัษณะของกราฟ 
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บทท่ี 10  

การเพิม่เติมขอมูลเขาสูคลังขอมูลใหทันสมัยอยางตอเนื่อง 
คลังขอมูลที่จัดทําขึ้นสําเร็จแลว จะใชไดดีอยางตอเน่ืองได ก็ตองมีการเพิ่มเติมขอมูลใหมเขาไปใหทันสมัยอยู

ตลอดเวลา การเพิ่มเติมขอมูลเขาสูคลังขอมูลโดยใชโปรแกรม Qlikview น้ัน ทําไดโดยงาย โดยมีขั้นตอนที่สําคัญคือ 

1. เพิ่มเติมขอมูลเขาสูแหลงขอมูลที่เชื่อมตอกับคลังขอมูล เชน ถาแหลงขอมูลมาจาก ไฟล Excel ใด ก็ตอง

บันทึกขอมูลใหมเขาสูไฟลน้ันเสียกอน 

2. ใชคําส่ัง Reload นําเขาขอมูล ตามภาพดังตอไปน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เม่ือเลือกเมนู File => Reload จะปรากฏหนาจอแสดงการ Reload ขอมูลดังน้ี 
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การ Reload อาจใชเวลามากถาปริมาณขอมูลมีมาก โดย Qlikview จะ Reload ขอมูลใหมทั้งชุด มิใช 

Reload เฉพาะขอมูลใหมที่เปล่ียนแปลง 
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